Showing results for 
Search instead for 
Did you mean: 
Community Manager

Movidius stick not showing up with lsusb and it is making weird sounds..

Hee guys,


I bought my Intel Movidius stick a while ago and I am trying to set it up right now.


I got my docker container with the ncsdk2 working.


I tried to make the examples and there is where the problems start..


It said that it couldn't find a USB device and therefore could not create the examples.


Than I tried to find the USB using lsusb.


It was not showing up.


I also tried: cat /sys/bus/usb/devices/*/product.


Again nothing showing up.


Than I tried multiple operating systems, no difference.


When I was walking around with the stick I noticed that is was making a sound.


I further inspected the sound


It was making a noise as if there was something in there that was loose and not properly connected.


Now my question:


Does anybody know on how to open it?


Or how to get a new one?


I live in Colombia and getting one was already quite hard and sending it back will be equally as hard or even harder.


So this is not preferable for me.


Every idea is welcome!

Tags (1)
0 Kudos
1 Reply
Community Manager

@Jelle, have you tried contacting the online vendor from whom you purchased the unit (mouser, amazon, RS Components)? I would recommend you to try and get a replacement before breaking open the device and voiding the warranty.