Community
cancel
Showing results for 
Search instead for 
Did you mean: 
adhikary__sunit
Beginner
166 Views

NCS 2 NC_DEVICE_NOT_FOUND After setting up usb variables

Output of dmesg

[ 4618.845115] usb 1-1: new high-speed USB device number 16 using xhci_hcd
[ 4618.986193] usb 1-1: New USB device found, idVendor=03e7, idProduct=2485
[ 4618.986198] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4618.986202] usb 1-1: Product: Movidius MyriadX
[ 4618.986205] usb 1-1: Manufacturer: Movidius Ltd.
[ 4618.986208] usb 1-1: SerialNumber: 03e72485
[ 4635.212930] usb 1-1: USB disconnect, device number 16
[ 4637.486529] usb 1-1: new high-speed USB device number 17 using xhci_hcd
[ 4637.626809] usb 1-1: New USB device found, idVendor=03e7, idProduct=2485
[ 4637.626815] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4637.626818] usb 1-1: Product: Movidius MyriadX
[ 4637.626822] usb 1-1: Manufacturer: Movidius Ltd.
[ 4637.626825] usb 1-1: SerialNumber: 03e72485

 

 

of lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 048d:c100 Integrated Technology Express, Inc.
Bus 001 Device 005: ID 045e:02f9 Microsoft Corp.
Bus 001 Device 004: ID 5986:06b0 Acer, Inc
Bus 001 Device 015: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 001 Device 007: ID 0cf3:e300 Atheros Communications, Inc.
Bus 001 Device 017: ID 03e7:2485  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

 

 

cat 97-usbboot.rules

ajnapackone@ajnapackone:/etc/udev/rules.d$ ls
70-snap.core.rules  97-usbboot.rules  99-openocd.rules
ajnapackone@ajnapackone:/etc/udev/rules.d$ cat 97-usbboot.rules
SUBSYSTEM=="usb", ATTRS{idProduct}=="2485", ATTRS{idVendor}=="03e7", GROUP="users", MODE="0666", ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEM=="usb", ATTRS{idProduct}=="2150", ATTRS{idVendor}=="03e7", GROUP="users", MODE="0666", ENV{ID_MM_DEVICE_IGNORE}="1"
SUBSYSTEM=="usb", ATTRS{idProduct}=="f63b", ATTRS{idVendor}=="03e7", GROUP="users", MODE="0666", ENV{ID_MM_DEVICE_IGNORE}="1"
ajnapackone@ajnapackone:/etc/udev/rules.d$

 

 

usb variables

ajnapackone@ajnapackone:~/Downloads/l_openvino_toolkit_p_2018.3.343$ sudo cat /etc/udev/rules.d/99-openocd.rules
SUBSYSTEM=="usb", ATTRS{idProduct}=="2485", ATTRS{idVendor}=="03e7", MODE="0666"

 

 

but when I run  sudo ./demo_squeezenet_download_convert_run.sh -d MYRIAD with NCS 2

[WARNING] All Model Optimizer dependencies are installed globally.
[WARNING] If you want to keep Model Optimizer in separate sandbox
[WARNING] run install_prerequisites.sh venv {caffe|tf|mxnet|kaldi|onnx}


###################################################

Convert a model with Model Optimizer

Target folder /home/ajnapackone/openvino_models/ir/squeezenet1.1 already exists. Skipping IR generation../demo_squeezenet_download_convert_run.sh: line 174: If you want to convert a model again, remove the entire ${$ir_dir} folder. ${run_again}: bad substitution


###################################################

Build Inference Engine samples

Target folder /home/ajnapackone/inference_engine_samples already exists. Skipping samples building.If you want to rebuild samples, remove the entire /home/ajnapackone/inference_engine_samples folder. Then run the script again

###################################################

Run Inference Engine classification sample

Run ./classification_sample -d MYRIAD -i /opt/intel/computer_vision_sdk_2018.3.343/deployment_tools/demo/../demo/car.png -m /home/ajnapackone/openvino_models/ir/squeezenet1.1/squeezenet1.1.xml

[ INFO ] InferenceEngine:
    API version ............ 1.2
    Build .................. 13911
[ INFO ] Parsing input parameters
[ INFO ] Loading plugin

    API version ............ 1.2
    Build .................. 13911
    Description ....... myriadPlugin
[ INFO ] Loading network files:
    /home/ajnapackone/openvino_models/ir/squeezenet1.1/squeezenet1.1.xml
    /home/ajnapackone/openvino_models/ir/squeezenet1.1/squeezenet1.1.bin
[ INFO ] Preparing input blobs
[ WARNING ] Image is resized from (787, 259) to (227, 227)
[ INFO ] Batch size is 1
[ INFO ] Preparing output blobs
[ INFO ] Loading model to the plugin
[ ERROR ] Can not init USB device: NC_DEVICE_NOT_FOUND
Error on or near line 208; exiting with status 1

 

 

however it works find with movidius without any issue. System details : I am suing lenovo y720 and all its ports are usb 3.0 , however I tried with usb 2.0 the problem persists.

 

0 Kudos
7 Replies
Hyodo__Katsuya
Innovator
166 Views

I upgraded to "OpenVINO toolkit 2018 R4 (2018.4.420)" and executed the following.
I do not know if it is a really effective method for you.
btw, I am working properly with the USB 3.1 port.

$ cd /opt/intel/common/mdf/lib64
$ sudo mv igfxcmrt64.so igfxcmrt64.so.org
$ sudo ln -s libigfxcmrt64.so igfxcmrt64.so

$ cd /opt/intel/mediasdk/lib64
$ sudo mv libmfxhw64.so.1 libmfxhw64.so.1.org
$ sudo mv libmfx.so.1 libmfx.so.1.org
$ sudo mv libva-glx.so.2 libva-glx.so.2.org
$ sudo mv libva.so.2 libva.so.2.org
$ sudo mv libigdgmm.so.1 libigdgmm.so.1.org
$ sudo mv libva-drm.so.2 libva-drm.so.2.org
$ sudo mv libva-x11.so.2 libva-x11.so.2.org
$ sudo ln -s libmfxhw64.so.1.28 libmfxhw64.so.1
$ sudo ln -s libmfx.so.1.28 libmfx.so.1
$ sudo ln -s libva-glx.so.2.300.0 libva-glx.so.2
$ sudo ln -s libva.so.2.300.0 libva.so.2
$ sudo ln -s libigdgmm.so.1.0.0 libigdgmm.so.1
$ sudo ln -s libva-drm.so.2.300.0 libva-drm.so.2
$ sudo ln -s libva-x11.so.2.300.0 libva-x11.so.2

 

adhikary__sunit
Beginner
166 Views

I tried the solution you have stated but the problem still persists. NCS2 does not get detected whatsoever but NCS1 works fine.

adhikary__sunit
Beginner
166 Views

[ INFO ] Loading IR to the plugin...
E: [xLink] [         0] dispatcherEventReceive:308    dispatcherEventReceive() Read failed -4 | event 0x7fbd8dd2eef0 USB_WRITE_REQ

E: [xLink] [         0] eventReader:254    eventReader stopped
E: [ncAPI] [         0] ncDeviceOpen:692    can't open stream

Traceback (most recent call last):
  File "segment_visualizeMyriad.py", line 272, in <module>

Tegwyn_Twmffat
New Contributor I
166 Views

I have exactly the same problem and performed the same steps as OP. I have tried neural network stick 1 successfully but stick 2 fails in exactly the same way as the above. Has anybody got a solution?

Tegwyn_Twmffat
New Contributor I
166 Views

Which was the last version of openvino_toolkit that worked properly?

Tegwyn_Twmffat
New Contributor I
166 Views

I have exactly the same problem - what is the fix?

whatthisismyname
Beginner
166 Views

 i am on linux and i had to restart :( is pretty rare on linux but i had to this time.