Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
510 Views

NCS1 Error - Could not open NCS device

Hi,

 

I am using NCS1 with Oracle VM(Ubuntu16.04) which install at desktop(Ubuntu18.04)

 

and I follow the steps of https://software.intel.com/en-us/movidius-ncs-get-started

 

it seems like NCSDK install success

 

I added both USB filter which Vender ID = 03e7 & f63b

 

and I checked whether VM get NCS with command "lsusb"

 

I can see "> Bus 001 Device 003: ID 03e7:2150"

 

but when I use the command "make run"

 

at dir "~/ncsdk/examples/apps/hello_ncs_py"

 

it does not work everytime

 

mostly it fail and output error msg

 

 

"Error - Could not open NCS device."

 

but sometime it works

 

and will output msg

 

"Hello NCS! Device opened normally./ Goodbye NCS! Device closed normally./ NCS device working."

 

I did not change any setting at all

 

 

One more thing plus,

 

I am not sure if it's related to the error

 

but I notice that everytime

 

I check USB with command "lsusb" everytime after I give the command "make run"

 

and the sequence number will plus 1

 

like this :

 

cd ncsdk/examples/apps/hello_ncs_py

 

lsusb

 

 

"Bus 001 Device 003: ID 03e7:2150"

 

make run

 

msg

 

lsusb

 

"Bus 001 Device 004: ID 03e7:2150"

 

 

but it still does not work.

 

Can anyone help?

 

Thanks.
0 Kudos
6 Replies
idata
Community Manager
134 Views

Hi @Yvonne.chou ,<br> Thanks for contacting us. This problem sounds very familiar and there are a few things that you can try to get it working. As I shared on this thread here https://ncsforum.movidius.com/discussion/1443/error-could-not-open-ncs-device#latest, the steps as explained below may help you resolve your problem. Although this was tested on Windows being the host OS and an Ubuntu 16.04 VM, it should apply to your environment. Find the relevant information and steps below:<br> .......................................................................................................................................................................................................................................................................................................... <ol> <li>Download and install Extension Pack from https://www.virtualbox.org/wiki/Downloads. Once installed make sure it reflects as Active in VirtualBox: File > Preferences > Extensions</li> <li>Make sure to Enable USB Controller and USB3.0 (xHCI) Controller is selected in VM Manager > Settings > USB</li> <li>Install NCSDK v1 (v2 should work too) with <code>make install</code> and <code>make examples</code> (may not be required if already done so)</li> <li>Unplug NCS from host machine and remove, if any, all USB filters in VM: Devices > Settings > USB > USB Settings > Remove Selected Filters</li> <li>Plug NCS to host machine and add a new USB filter in VM: Devices > USB > USB Settings > Add new USB filter with all fields set to values of selected device... > Movidius Ltd. Movidius MA2X5X [0001]. Click OK to apply changes</li> <li>Unplug NCS stick from host machine and plug it back in</li> <li>Run hello_ncs_py found in the examples <code><<path-to>>/ncsdk/examples/apps/hello_ncs_py</code> by executing <code>make run</code>. This should trigger the USB being unplugged noise, just let it do it's thing and <strong>DO NOT</strong> unplug the NCS</li> <li>Add a new USB filter in VM: Devices > USB > USB Settings > Add new USB filter with all fields set to values of selected device... > Movidius VSC Loopback Device [0100]. Click OK to apply changes</li> <li>Repeat items 6 and 7</li> </ol> ..........................................................................................................................................................................................................................................................................................................<br> Hope you find this helpful, let us know if this resolves the problem.<br> Regards, Luis
idata
Community Manager
134 Views

Thank you, Luis

 

re-pluging NCS seems solve current problem

 

But if I follow the steps of video(2:42) https://youtu.be/fESFVNcQVVA

 

it shows msg

 

 

[Error 7] Toolkit Error: USB Failure. Code: Error opening device

 

does re-plug solution only works with "hello_ncs.py"?

 

 

I wondering if there is any way that no need to re-plug NCS

 

and it can keep in connect with VM

 

Btw

 

there's another problem now

 

I download ncappzoo and try to run example"image-classifier" with command

 

git clone https://github.com/movidius/ncappzoo

 

cd ncappzoo/apps/image-classifier

 

make run

 

and occur following error msg

 

 

Exception: mvncStatus.ERROR

 

Makefile:41: recipe for target 'run' failed

 

make: ***[run]Error 1

 

 

thanks again.

idata
Community Manager
134 Views

I can not make examples now

 

the error msg below begin occur at the second part

 

 

[Error 7] Toolkit Error: USB Failure. Code: Error opening device

 

I believe it's relate to the re-plug issue

 

 

Also,

 

I've tried to run the example "ncsdk/examples/tensorflow/inception_vi"

 

by command make all but it failed at the second part

 

so I split it into three parts:

 

make profile

 

OK

 

replug

 

make check

 

OK

 

replug

 

make compile

 

OK

 

replug

 

make run

 

ERROR

 

 

make: execvp: ./run.py: Permission denied

 

Makefile:59: recipe for target 'run' failed

 

make: *** [run] Error 127

 

 

it seems like familiar with the error happen with example"ncappzoo/apps/image-classifier"

idata
Community Manager
134 Views

Hi @Yvonne.chou ,

 

That is interesting, did you get a chance to take a look at the steps I provided? I am fairly certain that those steps should resolve the re-plugging issue with your device. As far as the make examples is concerned, may I ask which version of the NCSDK and NCAPPZOO are you running? I've seen some issues where the versions don't match and throw some errors, specially when the NCAPPZOOv2 samples are being run using the NCSDKv1.

 

Regards,

 

@Luis_at_Intel
idata
Community Manager
134 Views

Hi @Luis_at_Intel ,

 

I've followed the steps you provided, but it still got the replugging issue

 

I also tried NCSDKv2,

 

none of them work.

 

So,

 

I use another desktop which is base on Win10 OS and an Ubuntu 16.04 VM,

 

and follow the steps again,

 

it works normally this time!

 

I am not sure if it is related to the host OS

 

or it just something wrong with my environment setting

 

thank you for your patient explanation

 

I'll let you know once I figure these out
idata
Community Manager
134 Views

Hi @Yvonne.chou ,

 

Thank you for the update and for sharing your results. If there are any further questions or comments don't hesitate to contact us.

 

Regards,

 

@Luis_at_Intel
Reply