Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.
5853 Discussions

OpenCV Error: GStreamer missing a required plugin(CentOS 7)

然_魏_
Beginner
1,195 Views

 

Platform:
——————————————————————————————————————————
[root@storm _build]# cat /proc/cpuinfo | grep name | cut -f2 -d: | uniq -c
      8  Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz
[root@storm _build]# lspci -nn -s 00:02.0
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412]

(rev 06)
——————————————————————————————————————————

Error Detail:
——————————————————————————————————————————
[root@storm FaceDetect_AVI_WR]# ./facedetect

This program demonstrates the cascade recognizer. Now you can use Haar or LBP features.
This classifier can recognize many kinds of rigid objects, once the appropriate classifier is trained.
It's most known use is for faces.
Usage:
./facedetect [--cascade=<cascade_path> this is the primary trained classifier such as frontal face]
   [--nested-cascade[=nested_cascade_path this an optional secondary classifier such as eyes]]
   [--scale=<image scale greater or equal to 1, try 1.3 for example>]
   [--try-flip]
   [filename|camera_index]

see facedetect.cmd for one call:
./facedetect --cascade="../../data/haarcascades/haarcascade_frontalface_alt.xml" --nested-cascade="../../data/haarcascades/haarcascade_eye.xml" --scale=1.3

During execution:
    Hit any key to quit.
    Using OpenCV version 3.0.0

OpenCV Error: Unspecified error (GStreamer: your gstreamer installation is missing a required plugin
) in handlemessage, file /root/Documents/linux_opencv-3.0.0/modules/videoio/src/cap_gstreamer.cpp, line 1622
terminate called after throwing an instance of 'cv::Exception'
  what():  /root/Documents/linux_opencv-3.0.0/modules/videoio/src/cap_gstreamer.cpp:1622: error: (-2) GStreamer: your gstreamer installation is missing a required plugin
 in function handlemessage

Aborted (core dumped)
[root@storm FaceDetect_AVI_WR]#
——————————————————————————————————————————


Problem Description:
__________________________________________

This is official program(with OpenCV3.0.0) and could run on Windows 7 (VS2012)

and I try to install gstreamer* (already installed several times):

[root@storm data]# yum install gstreamer-plugins-*
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.ustc.edu.cn
 * extras: ftp.sjtu.edu.cn
 * rpmforge: apt.sw.be
 * updates: centos.ustc.edu.cn
Package gstreamer-plugins-base-tools-0.10.36-10.el7.x86_64 already installed and latest version
Package gstreamer-plugins-bad-devel-0.10.8-5.el5.rf.x86_64 is obsoleted by gstreamer-plugins-bad-free-devel-0.10.23-20.el7.x86_64 which is already installed
Package gstreamer-plugins-base-0.10.36-10.el7.x86_64 already installed and latest version
Package gstreamer-plugins-good-0.10.31-11.el7.x86_64 already installed and latest version
Package gstreamer-plugins-base-devel-0.10.36-10.el7.x86_64 already installed and latest version
Package gstreamer-plugins-good-devel-docs-0.10.31-11.el7.noarch already installed and latest version
Package gstreamer-plugins-bad-free-devel-docs-0.10.23-20.el7.x86_64 already installed and latest version
...
Error: Package: gstreamer-plugins-ugly-0.10.11-2.el5.rf.x86_64 (rpmforge)
           Requires: libcdio.so.7()(64bit)
           Available: libcdio-0.77-1.el5.rf.x86_64 (rpmforge)
               libcdio.so.7()(64bit)
           Installed: libcdio-0.92-1.el7.x86_64 (@anaconda)
              ~libcdio.so.15()(64bit)
Error: Package: gstreamer-plugins-bad-0.10.8-5.el5.rf.x86_64 (rpmforge)
           Requires: libSoundTouch.so.0()(64bit)
           Available: soundtouch-1.3.1-1.el5.rf.x86_64 (rpmforge)
               libSoundTouch.so.0()(64bit)
           Installed: soundtouch-1.4.0-9.el7.x86_64 (@anaconda)
              ~libSoundTouch.so.1()(64bit)
Error: Package: gstreamer-plugins-ugly-0.10.11-2.el5.rf.x86_64 (rpmforge)
           Requires: libdvdread.so.3()(64bit)
           Available: libdvdread-0.9.4-0.el5.rf.x86_64 (rpmforge)
               libdvdread.so.3()(64bit)
           Available: libdvdread-0.9.7-1.el5.rf.x86_64 (rpmforge)
               libdvdread.so.3()(64bit)
           Installed: libdvdread-4.2.0-6.el7.x86_64 (@anaconda)
              ~libdvdread.so.4()(64bit)
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
ant-1.9.2-9.el7.noarch has missing requires of java-devel >= ('0', '1.5.0', None)
[root@storm data]#
__________________________________________________________________________________


What should I do? can anyone help me? Thanks~

0 Kudos
3 Replies
然_魏_
Beginner
1,195 Views

This problem has already been sloved.

Thank you for your attention~

Robert_I_Intel
Employee
1,195 Views

Hi,

If you care to describe how you solved this issue, please let us know. It could be of interest to the general OpenCV community.

Thank you!

然_魏_
Beginner
1,195 Views

Robert Ioffe (Intel) wrote:

Hi,

If you care to describe how you solved this issue, please let us know. It could be of interest to the general OpenCV community.

Thank you!

well, you don't need to worry about this problem and you may never encounter such situation without GFW.
I suppose almost no one from mainland China. If you are, try this:
install the following packages MANUALLY :
gstreamer1-vaapi-0.5.8-5.el7.nux
gstreamer1-libav1.0.6-1.el7.nux.x86_64
gstreamer1-vaapi-devel-0.5.9-3.el7.x86_64
the above packages automatic on-line installing is blocked by GFW, and I just tried it in CentOS7.1, if it doesn't works in you system, just prayer...
 

Reply