Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Morgan1
Beginner
200 Views

OpenVINO install_prerequisites.bat not running on Windows 10

Jump to solution

I've been trying to install OpenVINO on my Windows 10 computer by following the installation instructions on the OpenVINO website. I keep getting the attached error when I get to the step of running install_prerequisites.bat as well as when I try to configure the model optimizer for each framework separately also. I have the most recent release of tensorflow, 2.4.1, so I'm not quite sure how to resolve this issue.

Can anyone please offer any assistance?

Labels (2)
0 Kudos
1 Solution
Wan_Intel
Moderator
110 Views

Hi Morgan1,


Good to know that you are using Python 3.8.9 (64-bit) on your computer.


Which OpenVINO™ version you are using?

I was able to generate the same error when I use the OpenVINO™ version 2020.3 and below. This is because Python 3.8 is only supported by OpenVINO™ version 2021.1 onwards.


Thus, please install the OpenVINO™ version 2021.2 and give it a try. Do come back to us if your issue still persists.



Regards,

Wan


View solution in original post

5 Replies
Wan_Intel
Moderator
149 Views

Hi Morgan1,

 

Thanks for reaching out to us.

 

I’ve investigated your issue, and the reason for your error is that you are using Python 3.8.9 (32-bit). Intel® Distribution of OpenVINO™ toolkit requires Python 64-bit, as mentioned here.

 

Which Python edition (32-bit or 64-bit) are you using? You can check your Python edition by typing “python” in the Command Prompt.

 

Please install Python 3.8.9 (64-bit) and give a try to run the install_prerequisites.bat again.



Regards,

Wai Fook


Morgan1
Beginner
142 Views

Hello Wai,

Thank you for your response. I do have the 64-bit version of python 3.8.9 installed. When I run the command you provided, this is what I get:

Python 3.8.9 (tags/v3.8.9:a743f81, Apr 6 2021, 14:02:34) [MSC v.1928 64 bit (AMD64)] on win32

Do you have any other suggestions of what I might try to get OpenVINO working?

 

Thank you,

Morgan

Wan_Intel
Moderator
111 Views

Hi Morgan1,


Good to know that you are using Python 3.8.9 (64-bit) on your computer.


Which OpenVINO™ version you are using?

I was able to generate the same error when I use the OpenVINO™ version 2020.3 and below. This is because Python 3.8 is only supported by OpenVINO™ version 2021.1 onwards.


Thus, please install the OpenVINO™ version 2021.2 and give it a try. Do come back to us if your issue still persists.



Regards,

Wan


View solution in original post

Morgan1
Beginner
72 Views

Hello Wan,

This did resolve the issue. Thank you so much for your help!

 

Best,

Morgan

Wan_Intel
Moderator
63 Views

Hi Morgan1,


This thread will no longer be monitored since this issue has been resolved. If you need any additional information from Intel, please submit a new question.



Regards,

Wan


Reply