Intel® Distribution of OpenVINO™ Toolkit
Community support and discussions about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all things computer vision-related on Intel® platforms.
5766 Discussions

Openvino deployment on older CPU versions of Intel hardware

vkana3
Beginner
338 Views

Hi, I am Vishnu

I want to deploy a vehicle detector for detecting vehicles and classifying their models, in a parking lot, I have plenty of desktops connected to the cameras. But I have older versions of intel hardware ie.., 3rd gen and 4th gen of intel processors, and some of them have windows 7 and very few have windows 10.

 

Now, Can I deploy a vehicle detector and classifier on these systems?

0 Kudos
1 Solution
Wan_Intel
Moderator
292 Views

Hi Vishnu Kanamatareddy,

Thanks for your information.


For target system platforms, OpenVINO™ Toolkit requires 6th to 11th generation Intel® Core™ processors. OpenVINO™ Toolkit is not supported by 4th generation Intel Core Processor.


OpenVINO™ Toolkit is officially supported and validated on Windows 10 only.  OpenVINO™ Toolkit is not supported, not tested, and not validated on Windows 7.


This information is available under the section “Target System Platforms” in the System Requirements page:

https://software.intel.com/content/www/us/en/develop/tools/openvino-toolkit/system-requirements.html



Regards,

Wan


View solution in original post

4 Replies
Wan_Intel
Moderator
313 Views

Hi Vishnu Kanamatareddy,

Thank you for reaching out to us.


We regret to inform you that Windows 7, 3rd and 4th generation Intel Core processors are not supported by the OpenVINO™ toolkit.


OpenVINO™ toolkit is officially supported and validated on Windows 10, 6th to 11th generation Intel® Core™ and Intel® Xeon® processors only.


The system requirements for using the OpenVINO™ toolkit is available at the following page:

https://software.intel.com/content/www/us/en/develop/tools/openvino-toolkit/system-requirements.html



Regards,

Wan


vkana3
Beginner
308 Views

Thank you for your response @Wan_Intel 

 

But, For my current project I want to create a vehicle detector using c++ and deploy it in the windows 7 desktop which has 4th gen Intel processor.
 
Can I try creating a c++ based openvino application in windows 10 and then deploy the runtime package in the windows 7 desktop with the above configuration?
Wan_Intel
Moderator
293 Views

Hi Vishnu Kanamatareddy,

Thanks for your information.


For target system platforms, OpenVINO™ Toolkit requires 6th to 11th generation Intel® Core™ processors. OpenVINO™ Toolkit is not supported by 4th generation Intel Core Processor.


OpenVINO™ Toolkit is officially supported and validated on Windows 10 only.  OpenVINO™ Toolkit is not supported, not tested, and not validated on Windows 7.


This information is available under the section “Target System Platforms” in the System Requirements page:

https://software.intel.com/content/www/us/en/develop/tools/openvino-toolkit/system-requirements.html



Regards,

Wan


Wan_Intel
Moderator
269 Views

Hi Vishnu Kanamatareddy,


This thread will no longer be monitored since this issue has been resolved. 

If you need any additional information from Intel, please submit a new question.



Best regards,

Wan


Reply