Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Deng__Fucheng
Beginner
289 Views

Openvino with Intel Core graphics probelm

Hi,

I tried to do inference with -d GPU. The error shows:

ERROR: failed to create engine:Device lookup failed - unsupported device id:0x3E9B, Note:HD5xx+ devices are supported.

My CPU is i5 8300H, I checked , the processor graphics is UHD graphics 630. So openvino only supports HD graphics 5xxx, not others? 

The official website shows supported hardware includes 6th-8th generation Intel Core processors with Iris Pro graphics and Intel HD Graphics. But I tried HD Graphics 6000, it still did not work.

anyone could tell which ones  exactly openvino can support? Have anyone compared the performance for inference between CPU version and GPU version? Thanks 

0 Kudos
10 Replies
289 Views

do you have another video card and have the integrated card disabled? If not, try reboot. (seriously) If yes, you should switch on the integrated card. (from BIOS)

Deng__Fucheng
Beginner
289 Views

Shaoqiang C. (Intel) wrote:

do you have another video card and have the integrated card disabled? If not, try reboot. (seriously) If yes, you should switch on the integrated card. (from BIOS)

Hi, Shaoqiang, I tried it on two computers. One is NUC, ubuntu16.04LTS, Processor Intel Core i5-5250U, Graphics Intel HD Graphics 6000(Broadwell GT3); the other is laptop ubuntu 16.04LTS, Processor Intel Core i5-8300H, Graphics Gallium0.4 on llvmpipe(LLVM 4.0,256bits)(I removed the Nvidia driver for another video card). However, the results are same.

Could you tell me some sysetems or CPU configurations that work fine with integrated card under openvino? Because there is no clear official instruction. Thanks

289 Views

From OpenVINO doc, it needs 6th-8th generation Core. I think that's why your NUC with Core i5-5250U doesn't work. For your Core i5-8300H laptop, I recommand completely removing mesa drivers for Nvidia card. You can try this way:

1) Uninstall nouvea drivers:

$ sudo apt-get remove --purge nvidia*

2) Disable nouvea

$ sudo vi /etc/modprobe.d/blacklist-nouveau.conf

Add:

blacklist nouveau

options nouveau modeset=0

 

$sudo update-initramfs -u

$ reboot

3) if you still want to use Nvidia card, you can install driver from Nvidia.

$ sudo ./NVIDIA-Linux-x86_64-*.run  -no-nouveau-check -no-opengl-files

 

Good luck!

Shaoqiang

Yaniv
Beginner
289 Views

Hi,

I'm getting the same error: Device lookup failed - unsupported device id: 0x3E9B. Note: HD5xx+ devices are supported

I have a win10 core i7 8750H with UHD 630.

The device id 0x3E9B is actually the UHD 630.

Any advice?

Thanks

nikos1
Valued Contributor I
289 Views

Same issue here in one of our systems.

clDNN device ID bug or multi-GPU system issue?

 @ Yaniv

Do you have a discrete GPU in your system?

cheers,

nikos 

nikos1
Valued Contributor I
289 Views

I remember now - this will be solved when OpenVino gets the new clDNN 

UHD 630 is a good GPU for OpenVino 

Please refer to 

https://github.com/intel/clDNN/issues/47

and

https://github.com/intel/clDNN/issues/48

You could also build clDNN from source.

nikos

 

nikos1
Valued Contributor I
289 Views

Solution verified now and is the same as in https://software.intel.com/en-us/forums/computer-vision/topic/800809

- git checkout cldnn drop 9.1

( git checkout 049acb9ddac8d3ca11dae8513b9c16e2b7f9e53a )

- modify clDNN/src/caps/public/gpu_devices.inc

- build from source

- replace libclDNN64.so with the new one you built 

FWIW it works with both GPUs ; no need to disable or modify nouveau or any other BIOS settings 

Cheers,

nikos

Yaniv
Beginner
289 Views

Thanks nikos that's great help.

I'll try it next week. 

Yaniv
Beginner
289 Views

nikos wrote:

Solution verified now and is the same as in https://software.intel.com/en-us/forums/computer-vision/topic/800809

- git checkout cldnn drop 9.1

( git checkout 049acb9ddac8d3ca11dae8513b9c16e2b7f9e53a )

- modify clDNN/src/caps/public/gpu_devices.inc

- build from source

- replace libclDNN64.so with the new one you built 

FWIW it works with both GPUs ; no need to disable or modify nouveau or any other BIOS settings 

Cheers,

nikos

Solved my problem.

Thanks nikos.

BTW, version 5.0.1 still didn't fix it.

nikos1
Valued Contributor I
289 Views

> Solved my problem.

Good to hear! 

> BTW, version 5.0.1 still didn't fix it.

Correct, also realized this.

Cheers,

Nikos

 

Reply