Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
78 Views

Post training Optimizer Tool library conflicts

Jump to solution

I am currently running python 3.8.5 and have installed everything that is required up to this point (I believe) by going through the documentation.

 

I am trying to get the Post-training Optimizer Tool to work, mainly just using pot -h to verify it installed correctly. However, I keep getting:

 

DistributionNotFound: The 'scipy==1.2.1' distribution was not found and is required by pot

after running "pot -h" on my terminal. When I try and downgrade my scipy version through my anaconda environment it says:

  • scipy=1.2.1 -> python[version='>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']

meaning my python version is unsupported?

 

I have made another environment at python 3.7 but after everything is installed I get this error in the question I asked earlier: https://community.intel.com/t5/Intel-Distribution-of-OpenVINO/TypeError-Shared-Cython-type-cython-fu...

 

Any help will be greatly appreciated, I have not been able to get past this step for a few days.

 

Labels (1)
0 Kudos

Accepted Solutions
Highlighted
Novice
27 Views

This is for anyone who comes across this error in the future. I finally got it to work.  This is also in reply to this post I made: https://community.intel.com/t5/Intel-Distribution-of-OpenVINO/TypeError-Shared-Cython-type-cython-fu...

 

DO NOT USE PYTHON 3.8 because there are module conflicts such as pandas, scipy, and others that do not play nicely with this version (Anaconda environment would not let me install the necessary modules to do POT). Even after getting Python 3.7 installed, I was still getting the error as mentioned above. I suspected that it was due to the OpenVino environment variables still being initialized for my Python 3.8 version so I closed and reopened a new terminal. Still got the same error. 

 

The fix was removing the OpenVino setup variables in my .bashrc that I had included so i wouldn't have to always set them when opening a new terminal. After I manually did it in my Python 3.7 environment I was able to finally run the POT and added the environment setup again to .bashrc.

Hopefully this helps someone in the future as it stumped me for awhile.

View solution in original post

0 Kudos
4 Replies
Highlighted
Moderator
62 Views

Greetings,


I suggest that you get all pre-requisite for OpenVINO toolkit and ensure you are able to run the demo as instructed in below documentation.

You may refer to this official documentation: https://docs.openvinotoolkit.org/latest/openvino_docs_install_guides_installing_openvino_windows.htm...


(ensure that you are choosing the correct environment, eg: windows,Linux,etc)


Next, you may follow the setup for POT which you can refer here: https://docs.openvinotoolkit.org/latest/pot_README.html


Sincerely,

Iffa


0 Kudos
Highlighted
Moderator
41 Views

Greetings,


Intel will no longer monitor this thread since we have provided a solution. If you need any additional information from Intel, please submit a new question.


Sincerely,

Iffa


0 Kudos
Highlighted
Novice
28 Views

This is for anyone who comes across this error in the future. I finally got it to work.  This is also in reply to this post I made: https://community.intel.com/t5/Intel-Distribution-of-OpenVINO/TypeError-Shared-Cython-type-cython-fu...

 

DO NOT USE PYTHON 3.8 because there are module conflicts such as pandas, scipy, and others that do not play nicely with this version (Anaconda environment would not let me install the necessary modules to do POT). Even after getting Python 3.7 installed, I was still getting the error as mentioned above. I suspected that it was due to the OpenVino environment variables still being initialized for my Python 3.8 version so I closed and reopened a new terminal. Still got the same error. 

 

The fix was removing the OpenVino setup variables in my .bashrc that I had included so i wouldn't have to always set them when opening a new terminal. After I manually did it in my Python 3.7 environment I was able to finally run the POT and added the environment setup again to .bashrc.

Hopefully this helps someone in the future as it stumped me for awhile.

View solution in original post

0 Kudos
Highlighted
Novice
25 Views

Also, this was for version 2021.1 for future context.

0 Kudos