Intel® Distribution of OpenVINO™ Toolkit
Community assistance about the Intel® Distribution of OpenVINO™ toolkit, OpenCV, and all aspects of computer vision-related on Intel® platforms.
6414 Discussions

Questions about make run in Movidius ncappzoo-- recipe for target




Sorry to bother you again.

As I need to use Intel NCS2, I download ncappzoo and would like to run examples in the files. However, every file in the ncappzoo when I run them says Makefile:21: recipe for target 'compile_default_model' failed make: *** [compile_default_model] Error 255 or just like this.


I was wondering if it was possible for you to give me any constructive advice about them.

F:\ncappzoo\apps\benchmark_ncs>C:\MinGW\bin\make run
'\033[1;33m''\n'benchmark_ncs": No data needed."'\033[0m'
'\033[1;33m''\n'benchmark_ncs": Compiling the model"'\033[0m'
此时不应有 googlenet-v1.xml。
Makefile:21: recipe for target 'compile_default_model' failed
make: *** [compile_default_model] Error 255

F:\ncappzoo\apps\benchmark_ncs>C:\MinGW\bin\make clean
'\033[1;33m''\n'benchmark_ncs": Cleaning up files...""'\033[0m'"
rm -f googlenet-v1.*
process_begin: CreateProcess(NULL, rm -f googlenet-v1.*, ...) failed.
make (e=2):
Makefile:96: recipe for target 'clean' failed
make: *** [clean] Error 2


However, when I ran make help or make install-reqs, it can work.

F:\ncappzoo\apps\benchmark_ncs>C:\MinGW\bin\make install-reqs
'\033[1;33m'"\n"benchmark_ncs": Checking installation requirements..."'\033[0m'
"No requirements needed."


F:\ncappzoo\apps\benchmark_ncs>C:\MinGW\bin\make help
"\nPossible make targets: ";
'\033[1;33m'"  make run or run_py"'\033[0m'"- runs the application";
'\033[1;33m'"  make help "'\033[0m'"- shows this message";
'\033[1;33m'"  make all "'\033[0m'"- makes everything needed to run but doesn't run";
'\033[1;33m'"  make data "'\033[0m'"- downloads data as needed";
'\033[1;33m'"  make deps "'\033[0m'"- makes/prepares dependencies";
'\033[1;33m'"  make install-reqs "'\033[0m'"- Installs requirements needed to run this sample on your system.";
'\033[1;33m'"  make uninstall-reqs "'\033[0m'"- Uninstalls requirements that were installed by the sample program.";
'\033[1;33m'"  make default_model "'\033[0m'"- compiles a default model to use when running";
'\033[1;33m'"  make clean "'\033[0m'"- removes all created content";


Thank you for your help!!


0 Kudos
1 Reply

ncappzoo Quick Start

If you have an Intel® NCS2 (or the first generation Intel® Movidus™ NCS) device and want to jump into the ncappzoo, follow these steps:

Clone the repo with the following command:

git clone

Run this command inside of any app/network folder to check your system software dependencies for that particular sample:

make install_reqs

If the script returns successfully, you're ready to run the app or network sample!


This from the website and after I ran make install-reqs, it says no requirements needed and is it right?

0 Kudos