Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Deepanshu
Beginner
113 Views

Unable to run mask rcnn demo

I successfully ran the squeeze_net and security_car demo on CPU and NCS2. But when I tried running openvino mask rcnn sample on ubuntu 16.04, it is showing the following error. Could someone help me with this ?

Following is the command that I tried running: 

$ python3 mo_tf.py --input_model /home/xt19i0024/Downloads/mask_rcnn_resnet101_atrous_coco_2018_01_28/frozen_inference_graph.pb
Model Optimizer arguments:
Common parameters:
        - Path to the Input Model:      /home/xt19i0024/Downloads/mask_rcnn_resnet101_atrous_coco_2018_01_28/frozen_inference_graph.pb
        - Path for generated IR:        /home/xt19i0024/intel/openvino_2019.1.144/deployment_tools/model_optimizer/.
        - IR output name:       frozen_inference_graph
        - Log level:    ERROR
        - Batch:        Not specified, inherited from the model
        - Input layers:         Not specified, inherited from the model
        - Output layers:        Not specified, inherited from the model
        - Input shapes:         Not specified, inherited from the model
        - Mean values:  Not specified
        - Scale values:         Not specified
        - Scale factor:         Not specified
        - Precision of IR:      FP32
        - Enable fusing:        True
        - Enable grouped convolutions fusing:   True
        - Move mean values to preprocess section:       False
        - Reverse input channels:       False
TensorFlow specific parameters:
        - Input model in text protobuf format:  False
        - Path to model dump for TensorBoard:   None
        - List of shared libraries with TensorFlow custom layers implementation:        None
        - Update the configuration file with input/output node names:   None
        - Use configuration file used to generate the model with Object Detection API:  None
        - Operations to offload:        None
        - Patterns to offload:  None
        - Use the config file:  None
Model Optimizer version:        2019.1.1-83-g28dfbfd
[ ERROR ]  Shape [-1 -1 -1  3] is not fully defined for output 0 of "image_tensor". Use --input_shape with positive integers to override model input shapes.
[ ERROR ]  Cannot infer shapes or values for node "image_tensor".
[ ERROR ]  Not all output shapes were inferred or fully defined for node "image_tensor".
 For more information please refer to Model Optimizer FAQ (<INSTALL_DIR>/deployment_tools/documentation/docs/MO_FAQ.html), question #40.
[ ERROR ]
[ ERROR ]  It can happen due to bug in custom shape infer function <function tf_placeholder_ext.<locals>.<lambda> at 0x7fbeba1d9488>.
[ ERROR ]  Or because the node inputs have incorrect values/shapes.
[ ERROR ]  Or because input shapes are incorrect (embedded to the model or passed via --input_shape).
[ ERROR ]  Run Model Optimizer with --log_level=DEBUG for more information.
[ ERROR ]  Exception occurred during running replacer "REPLACEMENT_ID" (<class 'extensions.middle.PartialInfer.PartialInfer'>): Stopped shape/value propagation at "image_tensor" node.
 For more information please refer to Model Optimizer FAQ (<INSTALL_DIR>/deployment_tools/documentation/docs/MO_FAQ.html), question #38.

                                                    ..............................................................

( I even checked the MO_FAQ question #38 but I was unable to figure it out )

0 Kudos
5 Replies
Shubha_R_Intel
Employee
113 Views

Dear Raju, Deepanshu,

First of all, you're using an extremely old version of OpenVino. We are now on 2019R1.1. Please upgrade to the latest.

But upgrading will not solve your problem.  The mask rcnn demo doesn't work on MYRIAD right now.  The MYRIAD device literally runs out of memory. It's being addressed by the development team right now.

I'm very sorry about this. Thanks for your patience !

Shubha

Shubha_R_Intel
Employee
113 Views

Dear Raju, Deepanshu,

Also regarding your model optimizer error, you're not using the correct mo_tf.py command for Tensorflow Object Detection API. Please follow this document:

Tensorflow Object Detection API MO Support

Thanks,

Shubha

Deepanshu
Beginner
113 Views

Thanks for the quick response.

I think I had run the demo on the latest version itself. As you suggested upgrading the version to 2019R.1.1, so, I downloaded it again. I found out that the one I had previously downloaded and the one I downloaded recently are one and the same version/bits. Please correct me if I'm missing something. Here's the comparison:

xt19i0024@penna:~$ cksum ./Downloads/l_openvino_toolkit_p_2019.1.144.tgz ./openvino-toolkit/l_openvino_toolkit_p_2019.1.144.tgz
9203996 585457591 ./Downloads/l_openvino_toolkit_p_2019.1.144.tgz
9203996 585457591 ./openvino-toolkit/l_openvino_toolkit_p_2019.1.144.tgz
 

Shubha_R_Intel
Employee
113 Views

Dearest Deepanshu,

No  I think you're using the correct version of OpenVino. Are you saying that even after downloading the latest version of OpenVino and following the above instructions for Tensorflow Object Detection API, the mo command still fails for you ?

Thanks,

Shubha

 

Deepanshu
Beginner
113 Views

No, I could do the inference of mask_rcnn_demo on CPU on an image following the document that you shared. I just wanted to make sure that I've the latest version of OpenVino.

Thank you for addressing my query,

Deepanshu Raju

Reply