Community
cancel
Showing results for 
Search instead for 
Did you mean: 
daikon
Novice
95 Views

Why does it become "unsupported layer type" when I change the inference device?

Jump to solution

I have successfully changed the yolov5s onnx model to OpenVINO(.xml,.bin) format in OpenVINO 2021.2.
When I ran the inference, I was able to run it on the CPU.
However, on the GPU, I get the error "unknown layer type ScatterBDUpdate".
On MYRIAD, I get the error "unsupported layer type ScatterBDUpdate".

I know that OpenVINO 2021.2. does not support the conversion of yolov5s ONNX models.
Why is it possible to infer on the CPU, but not on the GPU or MYRIAD?

A similar phenomenon has occurred with other OpenVINO-supplied models.
/opencv/2021/openvinotoolkit/2021.2/open_model_zoo/models_bin/3/face-detection-adas-0001/FP16-INT8/face-detection-adas-0001.xml is I was able to infer it on CPU and GPU, but MYRIAD gave me an error "unsupported layer type FakeQuantize". Why does this difference occur?

Environment : docker image of openvino/ubuntu18-dev:latest on ubuntu18
CPU : Intel Corei3-6100@3.70GHz x4
MYRIAD : Neural Compute Stick 2

Tags (3)
0 Kudos

Accepted Solutions
Munesh_Intel
Moderator
70 Views

Hi Yuji,

Thanks for reaching out to us.

Yolov5 is not officially supported by OpenVINO, nor has it been validated by us.

 

For your first question, the layer ScatterUpdate is supported for CPU through extensions, but not supported for GPU and VPU(MYRIAD and HDDL). So that’s probably why you could run the model in CPU but not in GPU and MYRIAD. The relevant information is available in the following link:

https://docs.openvinotoolkit.org/2021.2/openvino_docs_IE_DG_supported_plugins_Supported_Devices.html...

 

For your second question, VPU plugin doesn’t support I8 model format.

The relevant information is available in the following link:

https://docs.openvinotoolkit.org/2021.2/openvino_docs_IE_DG_supported_plugins_Supported_Devices.html...

 


Regards,

Munesh


View solution in original post

3 Replies
Munesh_Intel
Moderator
71 Views

Hi Yuji,

Thanks for reaching out to us.

Yolov5 is not officially supported by OpenVINO, nor has it been validated by us.

 

For your first question, the layer ScatterUpdate is supported for CPU through extensions, but not supported for GPU and VPU(MYRIAD and HDDL). So that’s probably why you could run the model in CPU but not in GPU and MYRIAD. The relevant information is available in the following link:

https://docs.openvinotoolkit.org/2021.2/openvino_docs_IE_DG_supported_plugins_Supported_Devices.html...

 

For your second question, VPU plugin doesn’t support I8 model format.

The relevant information is available in the following link:

https://docs.openvinotoolkit.org/2021.2/openvino_docs_IE_DG_supported_plugins_Supported_Devices.html...

 


Regards,

Munesh


View solution in original post

daikon
Novice
61 Views

thank you !

Munesh_Intel
Moderator
34 Views

Hi Yuji,

This thread will no longer be monitored since we have provided a solution. If you need any additional information from Intel, please submit a new question.


Regards,

Munesh