Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
294 Views

dispatcherEventReceive() Read failed -4

Hi,

 

I'm trying to deploy a custom network. It compiles fine, but it hangs.

 

The examples in the ncsdk and the appzoo work fine.

 

Here is the relevant messages:

 

D\: [ 0] ncFifoWriteElem:2592 No layout conversion is needed 0

 

D\: [ 0] convertDataTypeAndLayout:170 src data type 1 dst data type 0

 

D\: [ 0] convertDataTypeAndLayout:172 SRC: w 4 h 1411 c 1 w_s 4 h_s 16 c_s 4

 

D\: [ 0] convertDataTypeAndLayout:174 DST: w 4 h 1411 c 1 w_s 2 h_s 8 c_s 2

 

D\: [ 0] ncFifoWriteElem:2617 write count 0 num_elements 2 userparam 0x7f0c9699c808

 

I: [ 0] ncGraphQueueInference:3048 trigger start

 

I: [ 0] ncGraphQueueInference:3145 trigger end

 

E: [ 0] dispatcherEventReceive:200 dispatcherEventReceive() Read failed -4

 

I'm on ubuntu 16.04, using V2.05.00 sdk.

 

Thanks.

 

Andrew
0 Kudos
9 Replies
Highlighted
Community Manager
40 Views

@Andrew Thanks for reporting this. I've come across similar issues myself while investigating networks and we're still looking to figure out what causes this issue. So far, from what I have seen, it seems to throw the read failed -4 message and hangs when I try to compile/check/profile a specific network (custom resnet 50). If you can provide a link to your model, it would be useful in debugging some of these issues. Thanks.

0 Kudos
Highlighted
Community Manager
40 Views

@Tome_at_Intel Thanks.

 

https://github.com/andrewzigerelli/learn-tensorflow-by-examples/tree/movidius

 

Sorry it's a messy project; I just wanted to get a working example.

 

I noticed from watching dmesg -wH, that USB number that it starts with disconnects, then reconnects with a different number.

0 Kudos
Highlighted
Community Manager
40 Views

Hi, I am trying to perform inference using a Tiny Yolo v2 and I am experiencing the same dispatcherEventReceive:200 error:

 

I: [ 0] ncGraphQueueInference:3048 trigger start

 

I: [ 0] ncGraphQueueInference:3145 trigger end

 

E: [ 0] dispatcherEventReceive:200 dispatcherEventReceive() Read failed -4

 

Were you able to find a solution?

 

I am running Movidius in an Intel NUC D54250WYKH with Ubuntu 16.04 installed.

0 Kudos
Highlighted
Community Manager
40 Views

I'm also having this issue on my network with -4 when using the profiler, no error when compiling, but -1 when attempting to inference. My investigation so far seems to have brought me to libusb_bulk_transfer() which appears to return -4 if there is no device, but a different error is returned for me if I don't have a device connected, so maybe it's crashing when running. -1 appears to be some kind of generic IO error.

0 Kudos
Highlighted
Community Manager
40 Views

I see this error with a U-net model if the output tensor is too large; e.g. an output of (63,63,1) is OK but (127,127,1) fails and hangs with this dispatcherEventReceive() Read failed -4

0 Kudos
Highlighted
Community Manager
40 Views

I worked out what it is for me in my case; it's a sigmoid operation i've got in my tensorflow graph at the output node. if i instead work on the logits output i don't have this error.

0 Kudos
Highlighted
Community Manager
40 Views

@matpalm I've got the same problem with a U-net using a sigmoid output. Can you elaborate on how you used logits as output?

0 Kudos
Highlighted
Community Manager
40 Views

for me it's literally just not using a sigmoid op in the model and applying the sigmoid operation explicitly on the NCS output

 

see https://github.com/matpalm/bnn/blob/ncs_poc/predict_on_ncs.py#L33
0 Kudos
Highlighted
Community Manager
40 Views

@feliphegaliza @Andrew @matpalm @mail929 Please try out NCSDK 2.08.01 at https://github.com/movidius/ncsdk/tree/ncsdk2 and let me know if you are still getting hangs. Thanks.

0 Kudos