Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DarkHorse
Employee
1,408 Views

openvino_2021.3.394 install_prerequisites

Jump to solution

Hi Expert,

This is done using openvino_2021.3.394, I am trying to run the install_prerequisites_tf2.bat file and I got this message at the end. Is this a warning or error messages?

\IntelSWTools\openvino_2021.3.394\deployment_tools\model_optimizer\install_prerequisites\..\mo\utils\extract_release_version.py') was unexpected at this time.

 

C:\Program Files (x86)\IntelSWTools\openvino_2021.3.394\deployment_tools\model_optimizer\install_prerequisites>install_prerequisites_tf2.bat
Python 3.8.9
ECHO is off.
Requirement already satisfied: tensorflow>=2.2 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from -r ..\requirements_tf2.txt (line 1)) (2.3.2)
Requirement already satisfied: networkx>=1.11 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from -r ..\requirements_tf2.txt (line 2)) (2.5.1)
Requirement already satisfied: numpy>=1.14.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from -r ..\requirements_tf2.txt (line 3)) (1.18.5)
Requirement already satisfied: test-generator==0.1.1 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from -r ..\requirements_tf2.txt (line 4)) (0.1.1)
Requirement already satisfied: defusedxml>=0.5.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from -r ..\requirements_tf2.txt (line 5)) (0.7.1)
Requirement already satisfied: requests>=2.20.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from -r ..\requirements_tf2.txt (line 6)) (2.25.1)
Requirement already satisfied: six in c:\users\allensen\appdata\roaming\python\python38\site-packages (from test-generator==0.1.1->-r ..\requirements_tf2.txt (line 4)) (1.15.0)
Requirement already satisfied: decorator<5,>=4.3 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from networkx>=1.11->-r ..\requirements_tf2.txt (line 2)) (4.4.2)
Requirement already satisfied: idna<3,>=2.5 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from requests>=2.20.0->-r ..\requirements_tf2.txt (line 6)) (2.10)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from requests>=2.20.0->-r ..\requirements_tf2.txt (line 6)) (1.26.4)
Requirement already satisfied: chardet<5,>=3.0.2 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from requests>=2.20.0->-r ..\requirements_tf2.txt (line 6)) (4.0.0)
Requirement already satisfied: certifi>=2017.4.17 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from requests>=2.20.0->-r ..\requirements_tf2.txt (line 6)) (2020.12.5)
Requirement already satisfied: protobuf>=3.9.2 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (3.15.7)
Requirement already satisfied: termcolor>=1.1.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (1.1.0)
Requirement already satisfied: h5py<2.11.0,>=2.10.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (2.10.0)
Requirement already satisfied: tensorboard<3,>=2.3.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (2.4.1)
Requirement already satisfied: opt-einsum>=2.3.2 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (3.3.0)
Requirement already satisfied: gast==0.3.3 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (0.3.3)
Requirement already satisfied: tensorflow-estimator<2.4.0,>=2.3.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (2.3.0)
Requirement already satisfied: wrapt>=1.11.1 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (1.12.1)
Requirement already satisfied: astunparse==1.6.3 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (1.6.3)
Requirement already satisfied: wheel>=0.26 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (0.36.2)
Requirement already satisfied: absl-py>=0.7.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (0.12.0)
Requirement already satisfied: google-pasta>=0.1.8 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (0.2.0)
Requirement already satisfied: keras-preprocessing<1.2,>=1.1.1 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (1.1.2)
Requirement already satisfied: grpcio>=1.8.6 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (1.32.0)
Requirement already satisfied: google-auth-oauthlib<0.5,>=0.4.1 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (0.4.4)
Requirement already satisfied: markdown>=2.6.8 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (3.3.4)
Requirement already satisfied: tensorboard-plugin-wit>=1.6.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (1.8.0)
Requirement already satisfied: setuptools>=41.0.0 in c:\users\allensen\appdata\local\programs\python\python38\lib\site-packages (from tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (49.2.1)
Requirement already satisfied: google-auth<2,>=1.6.3 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (1.28.0)
Requirement already satisfied: werkzeug>=0.11.15 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (1.0.1)
Requirement already satisfied: cachetools<5.0,>=2.0.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from google-auth<2,>=1.6.3->tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (4.2.1)
Requirement already satisfied: pyasn1-modules>=0.2.1 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from google-auth<2,>=1.6.3->tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (0.2.8)
Requirement already satisfied: rsa<5,>=3.1.4 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from google-auth<2,>=1.6.3->tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (4.7.2)
Requirement already satisfied: requests-oauthlib>=0.7.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from google-auth-oauthlib<0.5,>=0.4.1->tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (1.3.0)
Requirement already satisfied: pyasn1<0.5.0,>=0.4.6 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from pyasn1-modules>=0.2.1->google-auth<2,>=1.6.3->tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (0.4.8)
Requirement already satisfied: oauthlib>=3.0.0 in c:\users\allensen\appdata\roaming\python\python38\site-packages (from requests-oauthlib>=0.7.0->google-auth-oauthlib<0.5,>=0.4.1->tensorboard<3,>=2.3.0->tensorflow>=2.2->-r ..\requirements_tf2.txt (line 1)) (3.1.0)
\IntelSWTools\openvino_2021.3.394\deployment_tools\model_optimizer\install_prerequisites\..\mo\utils\extract_release_version.py') was unexpected at this time.

Labels (1)
0 Kudos
1 Solution
Peh_Intel
Moderator
1,231 Views

Hi DarkHorse,

 

I apologize for the miscommunication. The previously provided hyperlinks already added the quotation marks. It should be:

 

Original line 83:

set python_command='python %~dp0..\mo\utils\extract_release_version.py'

 

Edited line 73:

set python_command='python "%~dp0..\mo\utils\extract_release_version.py"'

 

Please add the quotation marks in the following lines as well:

Original line 93 to edited line 83

Original line 132 to edited line 122

Original line 150 to edited line 140

 

 

Regards,

Peh

 

View solution in original post

5 Replies
Peh_Intel
Moderator
1,381 Views

Hi DarkHorse,


Thanks for pointing it out.


I also get this message when running the install_prerequisites_tf.bat file and the install_prerequisites_tf2.bat file. By the way, I tried converting few public pre-trained models to IR. The conversion of the TensorFlow model to IR worked well.


As such, looking deeply into the script, this extract_release_version function is for capturing the release version. In my perspective, this message does not represent any warning or error.


On the other hand, I will highlight this finding to our development team for further feedback.



Regards,

Peh


Peh_Intel
Moderator
1,269 Views

Hi DarkHorse,

 

Glad to inform you that we are able to figure out this issue.

 

The default install directory of OpenVINO™ Toolkit is:

C:\Program Files (x86)\Intel\openvino_2021.3.394

 

For Windows, it is required to use quotation marks when specifying paths with spaces.

However, in the original script of install_prerequisites.bat file, there are missing quotation marks in the python_command and the errorlevel parts.

 

Hence, we need to add the quotation marks in line 73, 83, 122 and 140.

 

 

Regards,

Peh

 

DarkHorse
Employee
1,242 Views

Hello @Peh_Intel 

 

Just to confirm if I am doing the right thing:

1) Go to install_prerequisites.bat file
2) Line 83:  set "python_command"='python %~dp0..\mo\utils\extract_release_version.py'
3) Line 122: set "errorlevel"=
4) Line 141:  set "errorlevel"=

Let me know if this is correct.

 

Thanks.

Peh_Intel
Moderator
1,232 Views

Hi DarkHorse,

 

I apologize for the miscommunication. The previously provided hyperlinks already added the quotation marks. It should be:

 

Original line 83:

set python_command='python %~dp0..\mo\utils\extract_release_version.py'

 

Edited line 73:

set python_command='python "%~dp0..\mo\utils\extract_release_version.py"'

 

Please add the quotation marks in the following lines as well:

Original line 93 to edited line 83

Original line 132 to edited line 122

Original line 150 to edited line 140

 

 

Regards,

Peh

 

View solution in original post

Peh_Intel
Moderator
1,204 Views

Hi DarkHorse,

This thread will no longer be monitored since this issue has been resolved. If you need any additional information from Intel, please submit a new question. 



Regards,

Peh


Reply