Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,183 Views

protobuf: not installed, required: 3.6.1 ?

Jump to solution

Hi, I will convert googlenet-v4.caffemodel to IR, so I run mo.py as

python3 /opt/intel/computer_vision_sdk/deployment_tools/model_optimizer/mo.py --input_model ~/openvino_models/classification/googlenet/v4/caffe/googlenet-v4.caffemodel --scale 256 --mean_values [105,105,105] --output ~/openvino_models/ir/FP32/googlenet-v4

but error message appears,

Model Optimizer arguments:
Common parameters:
    - Path to the Input Model:     /home/shintani/openvino_models/classification/googlenet/v4/caffe/googlenet-v4.caffemodel
    - Path for generated IR:     /home/shintani/openvino_models/generate_IR/.
    - IR output name:     googlenet-v4
    - Log level:     ERROR
    - Batch:     Not specified, inherited from the model
    - Input layers:     Not specified, inherited from the model
    - Output layers:     /home/shintani/openvino_models/ir/FP32/googlenet-v4
    - Input shapes:     Not specified, inherited from the model
    - Mean values:     [105,105,105]
    - Scale values:     Not specified
    - Scale factor:     256.0
    - Precision of IR:     FP32
    - Enable fusing:     True
    - Enable grouped convolutions fusing:     True
    - Move mean values to preprocess section:     False
    - Reverse input channels:     False
Caffe specific parameters:
    - Enable resnet optimization:     True
    - Path to the Input prototxt:     /home/shintani/openvino_models/classification/googlenet/v4/caffe/googlenet-v4.prototxt
    - Path to CustomLayersMapping.xml:     Default
    - Path to a mean file:     Not specified
    - Offsets for a mean file:     Not specified
Model Optimizer version:     1.5.12.49d067a0
[ ERROR ]  
Detected not satisfied dependencies:
    protobuf: not installed, required: 3.6.1

Please install required versions of components or use install_prerequisites script
/opt/intel/computer_vision_sdk_2018.5.455/deployment_tools/model_optimizer/install_prerequisites/install_prerequisites_caffe.sh
Note that install_prerequisites scripts may install additional components.

This is on ubuntu 18.06, and I installed protobuf 3.6.1

$ protoc --version
libprotoc 3.6.1

How can I run this, or avoid this message ?

Best, Eigo

 

 

0 Kudos

Accepted Solutions
Highlighted
Novice
1,183 Views

The suggested `pip install --upgrade protobuf==3.6.1` did not work for me on my fresh Ubuntu 18.04 LTS install.

What worked for me was download the 3.6.1 release tar ball from https://github.com/protocolbuffers/protobuf/releases.

tar -xf protobuf-all-3.6.1.tar.gz
cd protobuf-3.6.1
./configure
make
make check
sudo make install
cd ./python
python3 setup.py build
python3 setup.py test
sudo python3 setup.py install

 

View solution in original post

0 Kudos
8 Replies
Highlighted
Employee
1,183 Views

Hello Eigo. Did you run the install_prerequisites script first as the error indicates ? 

0 Kudos
Highlighted
Beginner
1,183 Views

Hi Shubha,

Yes. curiously in the case of squeezenet, it is successful.

$python3 /opt/intel//computer_vision_sdk_2018.5.455/deployment_tools/model_optimizer/mo.py --input_model ~/openvino_models/models/FP32/classification/squeezenet/1.1/caffe/squeezenet1.1.caffemodel --output_dir ~/openvino_models/ir/FP32//classification/squeezenet/1.1/caffe --data_type FP32

Model Optimizer arguments:
Common parameters:
    - Path to the Input Model:     /home/shintani/openvino_models/models/FP32/classification/squeezenet/1.1/caffe/squeezenet1.1.caffemodel
    - Path for generated IR:     /home/shintani/openvino_models/ir/FP32//classification/squeezenet/1.1/caffe
    - IR output name:     squeezenet1.1
    - Log level:     ERROR
    - Batch:     Not specified, inherited from the model
    - Input layers:     Not specified, inherited from the model
    - Output layers:     Not specified, inherited from the model
    - Input shapes:     Not specified, inherited from the model
    - Mean values:     Not specified
    - Scale values:     Not specified
    - Scale factor:     Not specified
    - Precision of IR:     FP32
    - Enable fusing:     True
    - Enable grouped convolutions fusing:     True
    - Move mean values to preprocess section:     False
    - Reverse input channels:     False
Caffe specific parameters:
    - Enable resnet optimization:     True
    - Path to the Input prototxt:     /home/shintani/openvino_models/models/FP32/classification/squeezenet/1.1/caffe/squeezenet1.1.prototxt
    - Path to CustomLayersMapping.xml:     Default
    - Path to a mean file:     Not specified
    - Offsets for a mean file:     Not specified
Model Optimizer version:     1.5.12.49d067a0
[ WARNING ]  
Detected not satisfied dependencies:
    protobuf: installed: 3.0.0, required: 3.6.1

Please install required versions of components or use install_prerequisites script
/opt/intel/computer_vision_sdk_2018.5.455/deployment_tools/model_optimizer/install_prerequisites/install_prerequisites_caffe.sh
Note that install_prerequisites scripts may install additional components.

[ SUCCESS ] Generated IR model.
[ SUCCESS ] XML file: /home/shintani/openvino_models/ir/FP32//classification/squeezenet/1.1/caffe/squeezenet1.1.xml
[ SUCCESS ] BIN file: /home/shintani/openvino_models/ir/FP32//classification/squeezenet/1.1/caffe/squeezenet1.1.bin
[ SUCCESS ] Total execution time: 1.67 seconds.

 

Best,

Eigo

0 Kudos
Highlighted
Employee
1,183 Views

OK. This is interesting. Why not then try pip install --upgrade protobuf==3.6.1 ? Agreed you shouldn't have to do this. install_prerequsites.sh should take care of it. But can you try and see what happens ?

 

Thanks,

 

Shubha

0 Kudos
Highlighted
Beginner
1,183 Views

Hi Shubha,

Great, it is successful after pip;

$ pip install --upgrade protobuf==3.6.1
Collecting protobuf==3.6.1
  Downloading https://files.pythonhosted.org/packages/3a/30/289ead101f94998d88e8961a3548aea29417ae0057be23972483cd... (1.1MB)
    100% |████████████████████████████████| 1.1MB 3.5MB/s
Requirement already satisfied, skipping upgrade: setuptools in /home/shintani/anaconda3/lib/python3.7/site-packages (from protobuf==3.6.1) (40.6.3)
Requirement already satisfied, skipping upgrade: six>=1.9 in /home/shintani/anaconda3/lib/python3.7/site-packages (from protobuf==3.6.1) (1.12.0)
Installing collected packages: protobuf
Successfully installed protobuf-3.6.1

Thanks.

Best,

Eigo

0 Kudos
Highlighted
Novice
1,184 Views

The suggested `pip install --upgrade protobuf==3.6.1` did not work for me on my fresh Ubuntu 18.04 LTS install.

What worked for me was download the 3.6.1 release tar ball from https://github.com/protocolbuffers/protobuf/releases.

tar -xf protobuf-all-3.6.1.tar.gz
cd protobuf-3.6.1
./configure
make
make check
sudo make install
cd ./python
python3 setup.py build
python3 setup.py test
sudo python3 setup.py install

 

View solution in original post

0 Kudos
Highlighted
1,183 Views

Hello there!

 

I do have the a similar issue, It failed squeezenet1.1

[ ERROR ]

Detected not satisfied dependencies:

protobuf: not installed, required 3.6.1

 

I do have protobuf

ptotoc --version

libprotoc 3.11.1

 

Do I need to go back on version?

0 Kudos
Highlighted
Moderator
1,183 Views

Hi Virgen, Francisco,

Please try what Saw, Joo did, which is to install protobuf==3.6.1 manually from source. Make sure you uninstall the version you have currently installed prior doing this, let us know if you run into issues.

 

Regards,

Luis

0 Kudos
Highlighted
New Contributor I
1,102 Views

Most of the library are installed in roor directory. Please give it a try with sudo.

"""

cd /opt/intel/openvino/deployment_tools/demo

./demo_squeezenet_download_convert_run.sh

"""

Look closely the log text.

0 Kudos