Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
364 Views

undefined symbol: _ZN6google8protobuf8internal9ArenaImpl10AddCleanupEPvPFvS3_E

in the directory ncappzoo/apps/live-image-classifier ,i try to sudo make mobilenet,it have such error:

 

Exporting GraphDef file... (cd model; python3 /home/workspace/code/ncappzoo/tensorflow/mobilenets/../tf_models/models/research/slim/export_inference_graph.py \ --alsologtostderr \ --model_name=mobilenet_v1 \ --batch_size=1 \ --dataset_name=imagenet \ --image_size=224 \ --output_file=mobilenet_v1_1.0_224.pb;) Traceback (most recent call last): File "/home/workspace/code/ncappzoo/tensorflow/mobilenets/../tf_models/models/research/slim/export_inference_graph.py", line 62, in <module> from datasets import dataset_factory File "/home/workspace/code/ncappzoo/tensorflow/tf_models/models/research/slim/datasets/dataset_factory.py", line 21, in <module> from datasets import cifar10 File "/home/workspace/code/ncappzoo/tensorflow/tf_models/models/research/slim/datasets/cifar10.py", line 30, in <module> slim = tf.contrib.slim File "/usr/local/lib/python3.5/dist-packages/tensorflow/python/util/lazy_loader.py", line 53, in __getattr__ module = self._load() File "/usr/local/lib/python3.5/dist-packages/tensorflow/python/util/lazy_loader.py", line 42, in _load module = importlib.import_module(self.__name__) File "/usr/lib/python3.5/importlib/__init__.py", line 126, in import_module return _bootstrap._gcd_import(name[level:], package, level) File "/usr/local/lib/python3.5/dist-packages/tensorflow/contrib/__init__.py", line 33, in <module> from tensorflow.contrib import data File "/usr/local/lib/python3.5/dist-packages/tensorflow/contrib/data/__init__.py", line 63, in <module> from tensorflow.contrib.data.python.ops.error_ops import ignore_errors File "/usr/local/lib/python3.5/dist-packages/tensorflow/contrib/data/python/ops/error_ops.py", line 20, in <module> from tensorflow.contrib.data.python.ops import contrib_op_loader # pylint: disable=unused-import File "/usr/local/lib/python3.5/dist-packages/tensorflow/contrib/data/python/ops/contrib_op_loader.py", line 24, in <module> resource_loader.get_path_to_datafile("../../_dataset_ops.so")) File "/usr/local/lib/python3.5/dist-packages/tensorflow/contrib/util/loader.py", line 56, in load_op_library ret = load_library.load_op_library(path) File "/usr/local/lib/python3.5/dist-packages/tensorflow/python/framework/load_library.py", line 58, in load_op_library lib_handle = py_tf.TF_LoadLibrary(library_filename, status) File "/usr/local/lib/python3.5/dist-packages/tensorflow/python/framework/errors_impl.py", line 516, in __exit__ c_api.TF_GetCode(self.status.status)) tensorflow.python.framework.errors_impl.NotFoundError: /usr/local/lib/python3.5/dist-packages/tensorflow/contrib/data/python/ops/../../_dataset_ops.so: undefined symbol: _ZN6google8protobuf8internal9ArenaImpl10AddCleanupEPvPFvS3_E Makefile:69: recipe for target 'export' failed make[1]: *** [export] Error 1 make[1]: Leaving directory '/home/workspace/code/ncappzoo/tensorflow/mobilenets' Makefile:26: recipe for target 'mobilenet' failed make: *** [mobilenet] Error 2

 

another question:

 

in the directory ncappzoo/apps/live-image-classifier ,i try to sudo make run,it returns the following error:

 

ImportError: No module named caffe, so i add below code in Makefile:

 

ifneq ($(findstring movidius, $(PYTHONPATH)), movidius) export PYTHONPATH:=/opt/movidius/caffe/python:$(PYTHONPATH) endif

 

it works very well , i don't know if it is a bug for you.
Tags (1)
0 Kudos
8 Replies
Highlighted
Community Manager
38 Views

@Tome_at_Intel @PINTO ,can you help me? now i found out that all tensorflow's examples were wrong with the same error:

 

tensorflow.python.framework.errors_impl.NotFoundError: /usr/local/lib/python3.5/dist-packages/tensorflow/contrib/data/python/ops/../../_dataset_ops.so: undefined symbol: _ZN6google8protobuf8internal9ArenaImpl10AddCleanupEPvPFvS3_E

 

please help me,thanks!

0 Kudos
Highlighted
Community Manager
38 Views

0 Kudos
Highlighted
Community Manager
38 Views

0 Kudos
Highlighted
Community Manager
38 Views

@PINTO thanks very much, i install tensorflow 1.9.0 and it works!

0 Kudos
Highlighted
Community Manager
38 Views

@PINTO but the NCSDK 2.05 only supports tensorflow <= 1.7.0, my device is Raspberrypi 3, I have to face the problem directly,

0 Kudos
Highlighted
Community Manager
38 Views

@zufeifei

 

I know that.

 

It is not officially supported, but please be relief so that it works.

 

I and luna are operation verified.

 

If you dislike that you are not officially supported, I will not recommend it.

 

There is no doubt that the behavior of Tensorflow 1.7.0 is unstable.
0 Kudos
Highlighted
Community Manager
38 Views

@PINTO thanks for your time, and does it mean that I could remove tensorflow-1.7.0 and install the tensoflow with version 1.9.0 to solve the problem

0 Kudos
Highlighted
Community Manager
38 Views

@PINTO OH! I operation verified,

 

sudo pip3 uninstall tensorflow

 

sudo pip3 install tensorflow

 

then the problem solved,

 

thank you for a lot!
0 Kudos