Intel® Edge Software Hub
Get help on building Edge Software Hub solutions for edge compute node
Announcements
Welcome to the Intel Community! If you like the answer to your question, please mark it as 'Accepted Solution' to help others.

See our new article on Fidelity-first Ray Tracing in the Heterogeneous Compute Era.

The Edge Software Vision Package for Red Hat Enterprise Linux is now available here.

Learn more about developing on Intel® Hardware and Software here.

Eis Installation Failing

Rajnish
Beginner
537 Views

Hi All,

I am proceeding with root user for eis installation and it is failing while installing eis installer with below error message.Looking for help.

 

Command /usr/bin/python3 -u -cimport setuptools, tokenize;file='/tmp/pip-build-t73jamm3/onnx/setup.py';f=getattr(tokenize, 'open', open)(file);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, file, 'exec'))install --record /tmp/pip-xlxrm3x9-record/install-record.txt --single-version-externally-managed --compile failed with error code 1 in /tmp/pip-build-t73jamm3/onnx/

Found orphan containers (ia_etcd_provision, ia_etcd) for this project. If you removed or renamed this service in your compose file, you can run this command with the --remove-orphans flag to clean it up.
Building ia_eisbase
Building ia_common
Building ia_etcd_ui
Building ia_video_common
Building ia_openvino_base
Building ia_eis_azure_bridge
Building ia_azure_simple_subscriber
Building ia_factoryctrl_app
Building ia_imagestore
Building ia_influxdbconnector
Building ia_opcua_export
Building ia_rest_export
Building ia_tls_remoteagent
Building ia_video_analytics
Service 'ia_video_analytics' failed to build: The command '/bin/sh -c pip3.6 install -r va_requirements.txt && rm -rf va_requirements.txt' returned a non-zero code: 1

Failed to install : edge_insights_industrial. Check log files
Failed to install eis_installer took 1 minutes 38.49 seconds
Installation of package complete
+--------------------------+-----------------------------+---------+
| Id | Module | Status |
+--------------------------+-----------------------------+---------+
| 5f21392e9e63c9002a6fd88d | Docker Community Edition CE | SUCCESS |
| 5f213aae9e63c9002a6fd88e | Docker Compose | SUCCESS |
| 5ef46fe3fa5828002aa646e0 | eis installer | FAILED |
+--------------------------+-----------------------------+---------+

Labels (1)
0 Kudos
1 Solution
WengWai_C_Intel
Moderator
434 Views

It seem that you have some old container images, probably it will be good to clean it up in your system using the steps below:

1) docker system prune -a

2) docker rmi $(docker images -a -q)

3) Then use docker ps command to check and ensure no more containers are running, else please stop it and remove it.

4) Before you proceed, please move the ImageStore directory out from the IEdgeInsights directory. Then in the edge_insights_industrial directory, edit the file edgesoftware_configuration.xml by commenting the ImageStore component using <!-- <component/> --> , as example below:

<!-- <project path="installation/src" id="5ef237291c1b39002a684495" version="2.3.3" label="IEdgeInsights/ImageStore"/> -->

5) After done, rerun the ./edgesoftware install command at edge_insights_industrial directory.

After removing the old images from your system (ONNX build failure) and exclude ImageStore component in your build, this should be able to setup in your system. FYI,  I just did a freshly build verification, the ImageStore has a component removed from the external repo. This will be feedback to the developer team to update asap.

thanks!

View solution in original post

10 Replies
WengWai_C_Intel
Moderator
512 Views

Hi @Rajnish ,

The installation should not be using root user as it can cause docker network connecting to internet if the system network is running behind proxy. Please see the recommendation in the other post below:

https://community.intel.com/t5/Intel-Edge-Software-Hub/Eis-Installation-Failing/m-p/1236238#M404

Rajnish
Beginner
504 Views

Problem still persists.......I made sure that system and docker proxy is correctly set as per documents.

It is unable to build video_analytics container.please find the attachment for the output logs inside /var/log/esb-cli/Edge_Insights_for_Industrial_2.3.3.

 

WengWai_C_Intel
Moderator
474 Views

Thanks for the info. In this case, you should see the install.log file also generated in  /var/log/esb-cli/Edge_Insights_for_Industrial_2.3.3/eis_installer directory. Can you provide this log file as well?

Besides, it will be good to verify your working directory permission as well since you did using root user to run the installation before. You can check the output for command "ls -l <directory>" for the below directories, these should not be under root as well :

1) Edge_Insights_for_Industrial_2.3.3/IEdgeInsights

2) /var/log/esb-cli/Edge_Insights_for_Industrial_2.3.3/

Rajnish
Beginner
469 Views

Hi Weng

Permissions for above mentioned folders is as follows:-

drwxrwxr-x 7 meerssd meerssd 4096 déc. 11 11:50 build
drwxrwxr-x 7 meerssd meerssd 4096 déc. 10 13:33 common
-rwxrwxr-x 1 meerssd meerssd 4782 déc. 10 13:33 CONTRIBUTING.md
drwxrwxr-x 5 meerssd meerssd 4096 déc. 10 13:33 EISAzureBridge
-rwxrwxr-x 1 meerssd meerssd 5019 déc. 10 13:33 Etcd_Secrets_and_MsgBus_Endpoint_Configuration.md
drwxrwxr-x 3 meerssd meerssd 4096 déc. 10 13:33 EtcdUI
drwxrwxr-x 2 meerssd meerssd 4096 déc. 10 13:33 FactoryControlApp
drwxrwxr-x 7 meerssd meerssd 4096 déc. 10 13:33 ImageStore
drwxrwxr-x 9 meerssd meerssd 4096 déc. 10 13:33 InfluxDBConnector
-rwxrwxr-x 1 meerssd meerssd 2940 déc. 10 13:33 Installing_docker_pre_requisites.md
drwxrwxr-x 2 meerssd meerssd 4096 déc. 10 13:33 licenses
-rwxrwxr-x 1 meerssd meerssd 44028 déc. 10 13:33 license.txt
drwxrwxr-x 3 meerssd meerssd 4096 déc. 10 13:33 OpcuaExport
-rwxrwxr-x 1 meerssd meerssd 2326 déc. 10 13:33 README_fpga.md
-rwxrwxr-x 1 meerssd meerssd 25195 déc. 10 13:33 README.md
drwxrwxr-x 2 meerssd meerssd 4096 déc. 10 13:33 RestDataExport
drwxrwxr-x 5 meerssd meerssd 4096 déc. 10 13:33 Samples
drwxrwxr-x 2 meerssd meerssd 4096 déc. 10 13:33 TLSRemoteAgent
drwxrwxr-x 9 meerssd meerssd 4096 déc. 10 13:33 tools
drwxrwxr-x 4 meerssd meerssd 4096 déc. 10 13:33 VideoAnalytics
drwxrwxr-x 7 meerssd meerssd 4096 déc. 10 13:33 VideoIngestion
drwxrwxr-x 2 meerssd meerssd 4096 déc. 10 13:33 Visualizer
drwxrwxr-x 3 meerssd meerssd 4096 déc. 10 13:33 WebVisualizer

 

drwxrwxr-x 2 meerssd meerssd 4096 déc. 11 11:07 Docker_Community_Edition_CE
drwxrwxr-x 2 meerssd meerssd 4096 déc. 11 11:08 Docker_Compose
drwxrwxr-x 2 meerssd meerssd 4096 déc. 11 11:08 eis_installer
-rw-rw-r-- 1 meerssd meerssd 236 déc. 11 11:52 install_status.json
-rw-rw-r-- 1 meerssd meerssd 62227 déc. 11 11:52 output.log

 

 

PFA for install.log file.

 

Rajnish
Beginner
463 Views

Hi weng,

problem still persists......looking forward for the help.Let me know for further quaries.

Thank You

WengWai_C_Intel
Moderator
456 Views

Hi @Rajnish ,

From the log file you shared, it still showing the previous 3rd party component package build issue in EISv2.3.2 , which fixed in 2.3.3 hotfix release now. In this case, can you run the following command:

1) Go into edge_insights_industrial/Edge_Insights_for_Industrial_2.3.3/IEdgeInsights/build directory

2) Run command docker-compose build --no-cache to build your containers again.

3) If successfully build, run command docker-compose up -d to start the containers

Please let me know the outcome.

Rajnish
Beginner
449 Views

Hi Weng,

Build is failing.please find the attachment for logs.Looking forward of your reply of it.

Thank You.

WengWai_C_Intel
Moderator
435 Views

It seem that you have some old container images, probably it will be good to clean it up in your system using the steps below:

1) docker system prune -a

2) docker rmi $(docker images -a -q)

3) Then use docker ps command to check and ensure no more containers are running, else please stop it and remove it.

4) Before you proceed, please move the ImageStore directory out from the IEdgeInsights directory. Then in the edge_insights_industrial directory, edit the file edgesoftware_configuration.xml by commenting the ImageStore component using <!-- <component/> --> , as example below:

<!-- <project path="installation/src" id="5ef237291c1b39002a684495" version="2.3.3" label="IEdgeInsights/ImageStore"/> -->

5) After done, rerun the ./edgesoftware install command at edge_insights_industrial directory.

After removing the old images from your system (ONNX build failure) and exclude ImageStore component in your build, this should be able to setup in your system. FYI,  I just did a freshly build verification, the ImageStore has a component removed from the external repo. This will be feedback to the developer team to update asap.

thanks!

View solution in original post

Rajnish
Beginner
430 Views

Hi weng,

Thanks for the dedicated support. Eis is successfully installed now ......!!

WengWai_C_Intel
Moderator
422 Views

Great, thanks for confirmation!

Reply