Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.
1060 Discussions

Error: 'C:/build/swbuild/SJ/nightly/18.1std/625/l64/work/modelsim/eda/sim_lib/altera_mf.v' doesn't exist.

SDesa16
Beginner
738 Views

Our design uses Altera PLL_50_100 instance. I am using questasim for simulation. I have installed the Altera libraries. Compilation goes through, but simulation hangs with last line being:

# Time: 90 Instance: tb_ov1_top.inst_PLL_50_100.altpll_component.cycloneiii_pll.pll3

When i break the simulation, I see below error:

# Break in Module cda_scale_cntr at /build/swbuild/SJ/nightly/18.1std/625/l64/work/modelsim/eda/sim_lib/altera_mf.v line 14688

# Error opening C:/build/swbuild/SJ/nightly/18.1std/625/l64/work/modelsim/eda/sim_lib/altera_mf.v

# Path name 'C:/build/swbuild/SJ/nightly/18.1std/625/l64/work/modelsim/eda/sim_lib/altera_mf.v' doesn't exist.

 

I am not sure where this path coming from :'C:/build/swbuild/SJ/nightly/18.1std/625/l64/work'

 

I can see all the libraries in the library list.

 

I have included below line in my tcl script:

vsim -t 1ns -L altera_ver -L lpm_ver -L sgate_ver -L altera_mf_ver -L altera_lnsim_ver -L fiftyfivenm_ver -L work -voptargs="+acc" ............

 

I am dealing with Altera lib for the first time. Can you let me know, what must be wrong here? I am stuck with this Altera lib issue. Any lead would be appreciated. Thanks in advance.

0 Kudos
3 Replies
RichardTanSY_Intel
458 Views
Apologize for the delay in response. Can you send me the design file? So I can try run it using Questasim and come back to you
0 Kudos
SDesa16
Beginner
458 Views

Thanks for reverting. The problem is solved now. I don't remember the exact solution. Probably when we re-installed the Altera libraries, things were fine. And the other thing i remember is, my simulation was getting stuck due to the TB code. Not sure, why the above messages were displayed when i broke the simulation. With above two fixes, things look good.

0 Kudos
RichardTanSY_Intel
458 Views
Glad to hear that your issue has been fixed.
0 Kudos
Reply