Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.
1162 Discussions

Floating license server setup required for floating license use with local computer RHEL 6 VM?


Do I need to setup a floating license server to use a floating license for a single local computer's RHEL 6 VM instance?


First, I went to the Intel Self Service Licensing Center and added a new computer for a floating license by providing the HW Address (terminal command ifconfig and getting the eth0 HWaddr value) on my Linux RHEL 6 Virtual Machine instance. I then clicked on "Create New License", selected the 2 products "Quartus II SE Floating" and "OpenCL SDK" under the name "Patrick Jang", selected the computer that I just added, and downloaded the license.dat file. 


Next, I followed the directions in section 4.2.5 "Set Up a Floating Network License on a Local Computer" here:


On my Quartus Pro installation on my linux VM, I went to Options -> License Setup. In the License File input, I selected the license.dat file I had just created and downloaded. I also made sure to delete the line that starts with SERVER, according to step #3 in the directions on the quartus_install.pdf document.


One other thing to note is that I'm unable to connect to the Intel FPGA website when selecting the "Connect to the Altera Self-Service Licensing Center" option on Quartus Pro startup.


When I asked my technical liaison who provided the floating licenses, she also followed the same steps and provided a license.dat file for me to point to, but I still saw the same errors. I never got my question of whether I needed to setup a floating license server answered, which makes me wonder if it's needed or not.


Any help would be greatly appreciated!



0 Kudos
1 Reply
New Contributor II

Hello PJang,


I have a license server running.

There I deactivated the license server software and started Q18.1.

I tried to point Q18.1 to the directory where my licenses were and tried to open an existing license file.

It did not recognise the licenses. (Quartus hung)

I am only familiar with a floating license but it seems that my experiment points into the direction that you need a license server with a floating license.


Best Regards,


0 Kudos