Intel® FPGA Software Installation & Licensing
Installation and Licensing that’s includes Intel Quartus® Prime software, ModelSim* - Intel FPGA Edition software, Nios® II Embedded Design Suite on Windows or Linux operating systems.

HLS with Quartus Lite on Windows

FabianO
Novice
877 Views

Hello everybody,

i'm trying to get the high level synthesis compiler to work, but i can´t get the init_hls.bat running without errors. I am unsure if all the software prerequisites are met. The "getting started guide" does not contain specific information about using the hls compiler with any Quartus lite editions. My OS is Windows 10, i have installed Quartus Lite versions 19.1 and 20.1, Microsoft Visual Studio 2017 Community, ModelSim 19.1 and HLS Pro 20.3 and 19.1 Standard.

 

When running the init_hls.bat from HLS Pro 20.3 i get the following information:

[i] INFO:
Taking this script's directory as the root
of the Intel(r) HLS Compiler installation:
'C:\intelFPGA_pro\20.3\hls\'

[i] INFO:
Quartus is available through your environment:
'C:\intelFPGA_lite\20.1\quartus\'->
'C:\intelFPGA_lite\20.1\quartus\'
This setup will make it available on your PATH:
'C:\intelFPGA_lite\20.1\quartus\bin64\quartus_sh.exe'

(-) ERROR:
Platform Designer was not installed with Quartus;
Install Platform Designer, or pick a Quartus installation
where Platform designer is already available.
PS C:\intelFPGA_pro\20.3\hls>

 

When running the init_hls.bat from HLS 19.1 i get the following information:

Assuming current directory (C:\intelFPGA\19.1\hls\) is root of i++

Will use QUARTUS_ROOTDIR=C:\intelFPGA_lite\20.1\quartus to find Quartus
for internal i++ use
INFORMATION: Es konnten keine Dateien mit dem angegebenen
Muster gefunden werden.
Will be using Modelsim at C:\intelFPGA_lite\19.1\modelsim_ase\win32aloem\

VisualStudio's link.exe is not on the path. Guessing its location.
Cannot find VisualStudio installation by looking at the environment.
If VisualStudio is installed, use VisualStudio Command Prompt to set all
required environment variables then rerun this script.

 

What version of Microsoft Visual Studio do i need for using HLS 19.1 with Quartus Lite 19.1?

I am fairly new to this, am i doing anything else wrong?

 

Thanks for yor help!

0 Kudos
1 Solution
FabianO
Novice
827 Views

Thank you for answering my questions.

I was able to solve the issue by changing to Quartus Prime Lite version 18.1, which has the hls compiler preinstalled and by using Microsoft Visual Studio 2010 Professional.

My second mistake was using the Microsoft PowerShell instead of the command line. Working with the command line, the path variable was correctly changed.

View solution in original post

3 Replies
AnilErinch_A_Intel
834 Views

Hi ,

Please refer to the below link


https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/hb/hls/archives/ug-hls-gett...

Please Follow the section

1.5. Initializing the Intel HLS Compiler Environment 

Make sure that you are using the native tools prompt with Windows as mentioned in the document.

Please let us know the feedback.

Thanks and Regards

Anil


FabianO
Novice
828 Views

Thank you for answering my questions.

I was able to solve the issue by changing to Quartus Prime Lite version 18.1, which has the hls compiler preinstalled and by using Microsoft Visual Studio 2010 Professional.

My second mistake was using the Microsoft PowerShell instead of the command line. Working with the command line, the path variable was correctly changed.

AnilErinch_A_Intel
817 Views

Hi ,

Glad to know that the issue is resolved.

Thanks for sharing your experience with the community.

Thanks and Regards

Anil


Reply