Community
cancel
Showing results for 
Search instead for 
Did you mean: 
LZhi01
Beginner
274 Views

can not install eclipse(v19.3) with ubuntu18.04

hello, i install eclipse with ubuntu 18.04, when i use eclipse,i got this error message "

root@smart-HP:~/intelFPGA_pro/19.3/nios2eds/bin# ./eclipse-nios2 

OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0

free(): invalid pointer

 

" and i can not use eclipse;what can i do next ?

 

0 Kudos
7 Replies
MEIYAN_L_Intel
Employee
139 Views

Hi,

From the message show you are installing the later version of JDK v8.0, but the version needed for eclipse is JDK v7.0.

Upon checking , there is a customer who face the same problem with you.

Could you try to set the environment variable as link below:

https://wiki.archlinux.org/index.php/Eclipse#Disable_GTK_3

If the problem still persist, please tell me as well.

Thanks

 

LZhi01
Beginner
139 Views

hello,    thank you email,i change the .ini file as below but,when i click OK button,the eclipse is disappered. i still can not use sbt.
MEIYAN_L_Intel
Employee
139 Views

Hi,

I am not able to look into the .ini file, could you try to upload the .ini file?

Thanks

LZhi01
Beginner
139 Views

你好,如附件所示,你是否可以远程帮我解决一下?谢谢。
LZhi01
Beginner
139 Views

hello,as shown in the attachment,can you help me solve it remotely by teamviewer?thank you
MEIYAN_L_Intel
Employee
139 Views

Hi,

I had reported this issue to developer. I will reply here once I receive the information from the developer.

Thanks

MEIYAN_L_Intel
Employee
139 Views

Hi,

Sorry for late reply.

You might need to try to set environment variable by prepending "SWT_GTK3=0" before starting eclipse.

 

For your information, Ubuntu is not officaially supported for the Nios II EDS.

 

Thanks

Reply