Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,948 Views

de2_70 fitter error!

hi.i have altera de2-70 board.quartus always eroring SW[7] on fitter . 

 

 

Error: Can't place multiple pins assigned to pin location Pin_AD25 (IOC_X95_Y2_N1) 

Info: Pin SW[7] is assigned to pin location Pin_AD25 (IOC_X95_Y2_N1) 

Info: Pin ~LVDS195p/nCEO~ is assigned to pin location Pin_AD25 (IOC_X95_Y2_N1) 

Info: Fitter preparation operations ending: elapsed time is 00:00:00 

Error: Can't fit design in device 

Error: Quartus II Fitter was unsuccessful. 2 errors, 0 warnings 

Error: Peak virtual memory: 237 megabytes 

Error: Processing ended: Tue Jun 16 21:28:52 2009 

Error: Elapsed time: 00:00:06 

Error: Total CPU time (on all processors): 00:00:04 

Error: Quartus II Full Compilation was unsuccessful. 4 errors, 48 warnings
0 Kudos
7 Replies
Altera_Forum
Honored Contributor I
342 Views

Dear Speak48, 

 

When using iSW[7] of the DE2-70 board there is a problem with PIN_AD25 that is default assigned for two purposes. Messages look similar to:  

 

info: pin ~lvds195p/nceo~ is reserved at location ad25  

error: can't place pins assigned to pin location pin_ad25 (ioc_x95_y2_n1)  

info: pin isw[7] is assigned to pin location pin_ad25 (ioc_x95_y2_n1)  

Steps:
  • In Quartus-II select menu Assignments>Device...  

  • Select button "device and pin options..."  

  • Select the tab "Dual-Purpose Pins"  

  • Under the list of "Dual-purpose pins:" change the "Value" property of nCEO to "Use as regular I/O".  

  • Click ok
Good Luck! 

 

edit: removed original screenshots...
Altera_Forum
Honored Contributor I
342 Views

i think sanmao has the issue explained well. 

 

however are you trying to embed images here? i get a prompt to put in my password for a .tw site...
Altera_Forum
Honored Contributor I
342 Views

Dear thepancake, 

 

thanks for pointing me out to this! Apparently images are not uploaded to http://www.alterforum.com . So I removed the unaccessable links to obvious screenshots.
Altera_Forum
Honored Contributor I
342 Views

thank you brother!

Altera_Forum
Honored Contributor I
342 Views

SanMao - thanks for the clear explanation. I had this problem and couldn't figure out what the heck was going on until I read your post, found through a google search.

Altera_Forum
Honored Contributor I
342 Views

Thanks. It solved the problem...

Altera_Forum
Honored Contributor I
342 Views

Fantastic! I was scratching my head over this issue today till i finally found this post.. Well explained..:)

Reply