Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
1081 Discussions

there is a problem with the demo"sd_card_audio"

Altera_Forum
Honored Contributor II
1,310 Views

hi, 

when i do the demo "DE2_SD_Card_Audio" ,i fellow the steps like below,my quartus version is 6.1 

Running the Design 

------------------ 

1) Launch the Quartus II 6.1 software. 

2) Open the DE2_SD_Card_Audio.qpf project located in the <install path>\DE2_SD_Card_Audio folder. (File menu -> Open Project) 

3) Open the Programmer window. (Tools menu -> Programmer) 

4) The DE2_SD_Card_Audio.pof programming file should be listed. 

Check the 'Program/Configure' box and set up the ASP programming hardware connection via the 'Hardware Setup' button. 

5) Press 'Start' to start programming. The design should now be programmed. 

6) Launch the Nios II IDE. 

7) Switch the workspace to the <install path>\DE2_SD_Card_Audio folder. 

8) Build the project. (Project menu -> Build All) 

9) Run the project on the board. (Run menu) 

there is a problem when i do the setp 8). the nios II ide said  

make -s all  

make: *** No rule to make target `C:/DE2/DE2_SD_Card_Audio/system_0.ptf', needed by `C:/DE2/DE2_demonstrations/DE2_SD_Card_Audio/hello_led_0_syslib/Debug/system_description/../obj/generated_app.mk-t'. Stop. 

Build completed in 1.156 seconds
0 Kudos
6 Replies
Altera_Forum
Honored Contributor II
88 Views

help me~~~~~~~~

Altera_Forum
Honored Contributor II
88 Views

There seems to be a discrepancy between the two paths "C:/DE2/DE2_SD_Card_Audio/" and "C:/DE2/DE2_demonstrations/DE2_SD_Card_Audio" 

Did you move the folder after installation?
Altera_Forum
Honored Contributor II
88 Views

no&#65292;I never moved the folder&#12290;the project directory is "C:/DE2/DE2_demonstrations/DE2_SD_Card_Audio"&#12290; 

and there is no folder at "C:/DE2/DE2_SD_Card_Audio/"&#12290;
Altera_Forum
Honored Contributor II
88 Views

Thank you, you're a genius&#12290;According to your tip&#65292;My problem has been solved&#12290;

Altera_Forum
Honored Contributor II
88 Views

 

--- Quote Start ---  

There seems to be a discrepancy between the two paths "C:/DE2/DE2_SD_Card_Audio/" and "C:/DE2/DE2_demonstrations/DE2_SD_Card_Audio" 

Did you move the folder after installation? 

--- Quote End ---  

 

Thank you, you're a genius&#12290;According to your tip&#65292;My problem has been solved&#12290;
Altera_Forum
Honored Contributor II
88 Views

Hey Tom1984, 

 

I am having the same problem, as you mentioned in your first post, can you please guide me in fixing it. Appreciate it.
Reply