Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
1049 Discussions

writing to flash memory on old and new DE1 boards

Altera_Forum
Honored Contributor I
819 Views

In our teaching lab we have a mix of older and newer DE1 boards, which we have discovered have different versions of the Spansion Flash chip. Using the Control Panel program v1.0 we can write a file to the Flash chip on the older boards with no problem, but with the newer boards the Flash memory is not written correctly (some bytes are written properly but most are left as FF). 

 

The obvious fix is to use the new version v2.0 or v2.0.1 of the Control Panel for the new board, but we are not able to Connect to the newer boards with v2 of Control Panel. The Control Panel gives the Warning "Failed to find the FPGA Board." So we cannot use the new Control Panel to write to the Flash. We have tried running the new Control Panel on many different computers (desktops, laptops, all running Windows 7), running different versions of Quartus from v9 through v14, including ones with the newest USB Blaster driver. None of them can connect to the DE1 board. We have no problem connecting to the boards using v1 of the Control Panel program, but then writing to the flash doesn't work correctly. 

 

There must be something we are missing, but what? Any suggestions would be appreciated.
0 Kudos
1 Reply
Altera_Forum
Honored Contributor I
49 Views

OK, I have solved this problem. In case others face this, here is what needed to be done: 

- we were missing the NIOS II EDS, which needs to be installed for the DE1 Control Panel v2 to connect. 

- we needed to change the USB Blaster driver to the one mentioned in the Altera knowledge base: 

https://www.altera.com/support/support-resources/knowledge-base/solutions/rd062$
Reply