Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
15 Views

1D model

Hello everyone. I am a student who is using the parallel studio XE version from Intel to compile a model code. the model code contains multiple .f and .f90 file. The originally written makefile was written for PGIf90 compiler but I rewrote the FLAGS in make file according to ifort compiler.

Here is my translation of the FLAGS:


FLAGS = -c -Mpreprocess -O -fast -pc 64 -Kieee -Mdclchk

FLAGS= -c -fp-model precise -O2 -traceback -check -fpe0 -auto -qopenmp -free

still a few of the .f and .f90 files are unable to compiler please help me out as I am a student totally new at fortran and I am stuck.

0 Kudos
2 Replies
Highlighted
Black Belt
15 Views

Often, there is no matching option in one compiler for one of the options provided by another compiler.

The options that you used for Ifort are somewhat contradictory; for example, -check and -O2. The former generates extra code to check subscripts, etc, and slows the resulting program. The latter asks for optimized code; one component of optimizing is not to do time-consuming checking.

As to the "unable to compile", we can help only if you display the messages, and enough of the code to place those messages in context.

In the initial stages of moving to a different compiler, it would be wise to enable checking, disable optimizations and run some verification runs to make sure that the results from Ifort match those from PGI.

0 Kudos
Highlighted
15 Views

Consult the Intel Fortran compiler options (ifort -? > ifort.txt) or: https://software.intel.com/en-us/fortran-compiler-developer-guide-and-reference-compiler-options

You will have to figure out what options as used by the earlier compiler (PGIf90) use in you make file are equivalent to the options used by ifort.

Jim Dempsey

 

0 Kudos