Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner

Can't Find "mkl_*.dll"

I've recently installed Visual Studio 2015 and Intel Fortran 16. under a windows 7(64) OS.  When I attempt to run my code I get an error

"Program can't start because mkl_intel_threaded.dll is missing from your computer. Try re-installing the program to fix this problem" A search for this dll locates it in 4 directories

C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2016.3.207\windows\redist\intel64_win\mkl
...\IA32_win\mkl
..2016.2.180\windows\redist\intel64_win\mkl
...\2016.2.180\windows\redist\IA32_win\mkl

I had originally only installed the fortran download package which I thought contained MKL.  After receiving the above message I tried installing the MKL download package separately and re-booted the computer.  It appears some environment or PATH variables are not being set by the installation.  I then tried running mklvars.bat from the ...\windows\mkl\bin directory and re-started the computer.  Still no luck... Do I need to manually edit the system environment and/or PATH variable(s). ?

I have the OpenMP conditional compilation flag, and the Process OpenMP directives flags set in the compiler.  This was a VS project that worked fine in an earlier installation.

Any help would be much appreciated!
Thanks

 

0 Kudos
1 Reply
Highlighted

For the past few releases,

For the past few releases, the location of the MKL DLLs has not been added to the system PATH environment variable by the installer. You'll need to do that manually. If you need more help, you can ask in the MKL forum.

Retired 12/31/2016
0 Kudos