Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
27425 Discussions

Comment line beginning with "C" is not shown in green in the editor.

Don_D_
New Contributor I
318 Views

Comment line beginning with "C" is not shown in green in the editor.  On an older PC, it was.  Compilation is correct in both cases.

0 Kudos
3 Replies
jimdempseyatthecove
Black Belt
318 Views

Is your file extension .F90? If so, you IDE is likely assuming the because this is a Free Format source file, the comment indicator is ! and not C in column 1.

I am assuming you are using Microsoft Visual Studio.

Jim Dempsey

Don_D_
New Contributor I
318 Views

I use fixed-format Fortran.  All of the source-code modules are type .for.  I am using VS 2010.

Here is the Command Line:

/nologo /O3 /Ob0 /Oy- /Qipo /I"Release/" /reentrancy:none /fixed /extend_source:132 /Qopenmp /Qdiag-error-limit:30000 /Qdiag-file:"Release\SYNOPSYS200_lib_.diag" /Qauto /align:rec4byte /align:commons /assume:byterecl /Qtrapuv /Qzero /fpe:1 /fp:precise /Qfp_port /fpconstant /Qftz /Qfp-stack-check /Qfp-speculation=safe /iface:cvf /module:"Release/" /object:"Release/" /Fd"Release\vc100.pdb" /traceback /check:none /libs:dll /threads /winapp /c

 

/nologo /debug:full /Od /heap-arrays0 /I"Debug/" /reentrancy:none /extend_source:132 /Qopenmp /Qopenmp-report1 /warn:unused /warn:truncated_source /Qauto /align:rec4byte /align:commons /assume:byterecl /Qtrapuv /Qzero /fpe:1 /fp:strict /Qfp_port /fpconstant /Qftz /Qfp-stack-check /iface:cvf /module:"Debug/" /object:"Debug/" /Fd"Debug\vc100.pdb" /traceback /check:all /libs:dll /threads /winapp /c

Steve_Lionel
Black Belt Retired Employee
318 Views

The command line used is not relevant. Please show a screenshot of Visual Studio with the source opened. Also show a screenshot of Tools > Options > Intel Compilers and Tools > Visual Fortran > General.

Reply