Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
9 Views

Compiling issue of intel fortran with ASPEN PLUS V10

While compiling intel fortran with ASPEN Plus v10 it shows the error messages. Please help.Screenshot (1).png

0 Kudos
14 Replies
Highlighted
Black Belt
9 Views

This is an ASPEN PLUS message

This is an ASPEN PLUS message - you will need to contact ASPEN PLUS support for help with this. I'm guessing, though, that their scripts have a list of specific compiler versions and that this list has not been kept up to date. (It's also a poor design.)

Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Black Belt
9 Views

The Aspen+ script seems to be

The Aspen Plus script seems to be searching for a match with an installed version of IVF from 10.0 to 17.0. What is the version of IVF that you have?

0 Kudos
Highlighted
9 Views

I installed intel parallel

I installed intel parallel studio xe 2018 cluster edition update 4 in my pc.

0 Kudos
Highlighted
Black Belt
9 Views

I do not know anything about

I do not know anything about Aspen Plus; in particular, whether it requires IVF to be present, or simply uses it if available, and whether it checks for the presence of a known version of IVF at installation time or during every run.

However, if Aspen Plus requires that Intel Fortran be installed, and checks for versions 10 to 17 of IVF by inspecting registry entries before a run, it could output error messages such as what you showed. 

0 Kudos
Highlighted
9 Views

ok

ok

0 Kudos
Highlighted
New Contributor I
9 Views

@choudhary, udit  This is way

@choudhary, udit  This is the way I fix the issue.

1. Find the file compilers.cfg in the AspenPlus installation folder. It is advisable to do a search for this file on the C:\ drive and make sure there are no duplicates.
2. MAKE A BACKUP COPY OF THE EXISTING FILE TO BE SAFE.
3. Add the following lines to the end of the file compilers.cfg and change the value of "170.109" in the second line to the version of the IVF compiler that you are using and "15.0" in the third line to that of the Microsoft Visual Studio Version
4. You will find the information required for 3 in the registry under the following (the values below are for the latest Intel Fortran compiler).
    \HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Intel\Compilers\Fortran\190.190
    \HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\VisualStudio\15.0
5. Now close AspenPlus and rerun the Compiler Setup Utility. You should be able to select your compiler and run it successfully.

Lines to be added to compilers.cfg

Begin IVF17_VS15 "Intel Fortran 17/2017 and Microsoft Visual Studio 15/2017"
IFDir=HKLM(SOFTWARE\Intel\Compilers\Fortran\170.109\ProductDir)
VSDir=HKLM(SOFTWARE\Microsoft\VisualStudio\15.0\InstallDir)\..\..
SDKDir=HKLM(SOFTWARE\Microsoft\Microsoft SDKs\Windows\v8.1\InstallationFolder)
KitDir=HKLM(SOFTWARE\Microsoft\Windows Kits\Installed Roots\KitsRoot10)
#!KitVer=GetVer($(KitDir)Include)
KitVer=10.0.10150.0
INCLUDE=$(IFDir)\Compiler\Include;$(IFDir)\Compiler\Include\IA32;$(VSDir)\VC\INCLUDE;$(VSDir)\VC\ATLMFC\INCLUDE;$(KitDir)\include\$(KitVer)\ucrt;$(SDKDir)\include\shared;$(SDKDir)\include\um;$(SDKDir)\include\winrt
LIB=$(IFDir)\Compiler\lib\IA32;$(VSDir)\VC\LIB;$(VSDir)\VC\ATLMFC\LIB;$(KitDir)\Lib\$(KitVer)\ucrt\x86;$(SDKDir)\Lib\winv6.3\um\x86
PATH=$(IFDir)\bin\IA32;$(VSDir)\Common7\IDE;$(VSDir)\VC\BIN;$(VSDir)\Common7\Tools;$(SDKDir)\bin\x86;$(PATH)
USE_COMPAQ_FORTRAN=
IFDir=
VSDir=
SDKDir=
KitDir=
KitVer=
End

 

0 Kudos
Highlighted
New Contributor I
9 Views

I would also check that the

I would also check that the following lines match those in your existing compilers.cfg.

SDKDir=HKLM(SOFTWARE\Microsoft\Microsoft SDKs\Windows\v8.1\InstallationFolder)
KitDir=HKLM(SOFTWARE\Microsoft\Windows Kits\Installed Roots\KitsRoot10)
#!KitVer=GetVer($(KitDir)Include)
KitVer=10.0.10150.0

 

0 Kudos
Highlighted
9 Views

When I made changes in

When I made changes in compilers.cfg file it save as .txt format not in cfg format.

0 Kudos
Highlighted
Valued Contributor II
9 Views

I guess you used an editor

I guess you used an editor like Notepad on Windows. You should understand that .txt is merely an indication that the file is a simple text file, i.e. readable by humans without the aid of specialised software or any specific structure other than lines of text. Rename it to compilers.cfg and you should be fine.

0 Kudos
Highlighted
9 Views

Can you make the changes in

Can you make the changes in this filr?

0 Kudos
Highlighted
Valued Contributor II
9 Views

Sorry, no. The contents of

Sorry, no. The contents of the file seem to be clear enough to see what needs to be done and I understood you already made these changes. My advice was merely to rename the file to "compilers.cfg", a very basic task.

0 Kudos
Highlighted
9 Views

now its showing this.

now its showing this.

Screenshot (7).png

0 Kudos
Highlighted
Valued Contributor II
9 Views

You expect too much from us:

You expect too much from us: most of us will not know ASPEN and this is clearly a problem that should be put to its developers.

We can help you with Fortran problems or problems related to the Intel Fortran compiler, but not with this configuration stuff from another provider. I do not mean to be rude, but I will ignore any further posts on this matter.

0 Kudos
Highlighted
9 Views

ok

ok

0 Kudos