Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
28603 Discussions

Does intel/oneapi/compiler/2022.1.0/mac/bin/intel64/ifort support MacOS Big Sur 11.7.10

tz0616
Beginner
355 Views

Hi,

My current MacOS is Mojave 10.14.6 and I use

"/opt/intel/oneapi/compiler/2022.1.0/mac/bin/intel64/ifort" to compile fortran code, it works well.

For some reason, I need to upgrade the MacOS to MacOS Big Sur 11.7.10.

I am not sure if the current ifort compiler will fail.

Thanks for your comments.

TZ

0 Kudos
1 Reply
andrew_4619
Honored Contributor III
338 Views

https://www.intel.com/content/www/us/en/developer/articles/system-requirements/oneapi-fortran-compiler-system-requirements.html

 

NOTE Intel oneAPI HPC Toolkit for macOS on x86 is discontinued in the 2024.0 release.  This includes Intel® Fortran Compiler Classic (ifort). Several Intel-led open source developer tool projects will continue supporting macOS on Apple Silicon including Intel® oneAPI Threading Building Blocks (oneTBB) and Intel® Implicit SPMD Program Compiler and we welcome the opportunity to work with contributors to expand support to additional tools in the future.

0 Kudos
Reply