Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
19 Views

Error code 23 (returned by OpenValidateX) opening pdb Debug\vc140.pdb

I have just done a clean install of Visual Studio Community 2015 and Intel Parallel Studio XE Pro 2016 using default settings for both of them on a new computer running Windows 10 Pro 64bit. I'm getting "Error code 23 (returned by OpenValidateX) opening pdb Debug\vc140.pdb" on every Fortran file during the compile when I try to do a build. I don't have any old versions of VS or Intel Fortran installed on this computer.
I don't have this problem with the same project being built on a different computer running Windows 8, VS2010 and Intel Parallel Studio XE Pro 2015.
Does anyone know the solution?
0 Kudos
8 Replies
Highlighted
19 Views

I see this too on every build

I see this too on every build in VS2015. It seems harmless, but I will be asking the developers about it.

Retired 12/31/2016
0 Kudos
Highlighted
19 Views

Try this. Do a Build > Clean

Try this. Do a Build > Clean on the solution. Then go into the project folder and delete all .pdb files you can find. See if the message goes away.

Retired 12/31/2016
0 Kudos
Highlighted
Novice
19 Views

It does seem to be harmless

I couldn't get rid of it with a clean and *.pdb delete, but it does seem to be harmless and only occurs with the Debug/Win32 build. The Release builds and the Debug/x64 build don't have the problem. I'll just ignore it for now.

0 Kudos
Highlighted
19 Views

It turns out that this is a

It turns out that this is a problem Microsoft has acknowledged and is planning to fix in a VS2015 update. It does seem to be generally harmless. We are tracking this with our issue DPD200569783. Workarounds are said to be:

     1.  Compile with the option /Z7 rather than /Zi or /debug:full 
     2.  Modify PATH such that 
               c:/Program files (x86)/Microsoft Visual Studio 14.0/VC/BIN 
          precedes 
               c:/Program files (x86)/Microsoft Visual Studio 14.0/Common7/IDE 
     3.  Rename the copy of mspdb140.dll residing in the directory 
          c:/Program files (x86)/Microsoft Visual Studio 14.0/Common7/IDE 

Retired 12/31/2016
0 Kudos
Highlighted
Beginner
19 Views

I had the "error code 23

I had the "error code 23 (returned by OpenValidateX) opening pdb Debug\vc140.pdb"
I changed the name of MSPdb140.dll to MSPdb140_Save.dll and the message went away.
Now I get "error #10037: could not find 'link'"
The only Link.exe I have is in C:\Program Files (x86)\Microsoft Visual Studio 12\VC\....
There is no Link.exe in the c:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\...
Can I use the one in VS12 ?

Windows 7 64 Bit

Visual Studio 2015

Intel Fortran Parallel Studio XE 2015

 

 

0 Kudos
Highlighted
Novice
19 Views

You might find that it is

You might find that it is easier to just ignore the error instead of renaming files and getting other errors. It seems to be harmless, plus for me it only occurs with Debug/32-bit builds. If you build for Release/32-bit or Debug/Release/64-bit then you shouldn't get the error.

0 Kudos
Highlighted
19 Views

Options 1 and 2 are the

Options 1 and 2 are the recommended workarounds.  Option 3 is not recommended due to the risk of impacting other applications as Dana has discovered.

 

0 Kudos
Highlighted
19 Views

It looks as if Microsoft

It looks as if Microsoft fixed this issue in VS2015 Update 1.

Retired 12/31/2016
0 Kudos