Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
23 Views

Execute_Command_line with Intel Visual Fortran Composer XE 2013

Hello,

I get a compilation error when calling the Execute_Command_Line in a program using The Intel Visual Fortran Composer XE 2013 with a Microsoft Visual Studio 2010 Shell. It asks me for an explicit interface for this subroutine.

The same code works perfectly without errors in a computer using VS 2015 and an Intel Parallel Studio XE 2017. Is there anything I can do to solve this ?

Thanks in advance for any help.

0 Kudos
1 Reply
Highlighted
Black Belt Retired Employee
23 Views

Upgrade the compiler. EXECUTE_COMMAND_LINE is a Fortran 2008 intrinsic that was first supported in the 2015 or maybe 2016 version of the compiler.

The 2013 version does support the SYSTEM portability routine which serves a similar purpose (but isn't identical.)

0 Kudos