Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor III

ICE with 17.2 compiling FOX (XML lib) --> solved (/debug-parameters)

Jump to solution

Hi,

PSXE2017 update 2 produces an ICE while compiling FOX (4.1.2, https://github.com/andreww/fox, http://fortranwiki.org/fortran/show/FoX) ; e.g. in file m_wkml_color.f90, where PSXE2017 update 1 compiles smoothly:

------ Build started: Project: FOXlib, Configuration: Debug|x64 ------

Compiling with Intel(R) Visual Fortran Compiler 17.0.2.187 [Intel(R) 64]...
m_wkml_color.F90
fortcom: Fatal: There has been an internal compiler error (C0000005).
compilation aborted for ...\FOX_XML\FoX-4.1.2\wkml\m_wkml_color.F90 (code 1)

the build log:

Compiling with Intel(R) Visual Fortran Compiler 17.0.2.187 [Intel(R) 64]...
ifort /nologo /debug:full /Od /fpp /assume:nocc_omp /warn:all /debug-parameters:used /Qinit:snan /fp:source /module:"x64\Debug\\" /object:"x64\Debug\\" /Fd"x64\Debug\vc140.pdb" /traceback /check:bounds /check:uninit /check:stack /libs:static /threads /dbglibs /c /Qlocation,link,"C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\\bin\amd64" /Qm64 "D:\02_Fortran\05_general_libraries\FOX_XML\FoX-4.1.2\wkml\m_wkml_color.F90"
fortcom: Fatal: There has been an internal compiler error (C0000005).
compilation aborted for ...\FOX_XML\FoX-4.1.2\wkml\m_wkml_color.F90 (code 1)


FOXlib - 1 error(s), 0 warning(s)

There are a lot of more files, where this ICE occurs. Unfortunately, I'm not able to find out, where or what is the trigger for this error. I put everything into VS 2015 and compile from there. Nevertheless 17.1 compiles without an error and an example program runs without errors, too. The sources can be found at the above mentioned link for reproducing the ICE. Let me know, if I could supply more information.

0 Kudos

Accepted Solutions
Highlighted
Employee

I suspect this is another

Jump to solution

I suspect this is another instance of an unfortunate regression introduced in PSXE 2017 Update 2 with the /debug-parameters option. I noted the case here also involves the debug build with /debug-parameters:used

Try disabling this option under the IDE: Properties > Fortran > Debugging > Information for PARAMETER Constants set to None

Let us know whether doing that helps work around the internal compiler errors.

View solution in original post

0 Kudos
4 Replies
Highlighted
Employee
1 View

I suspect this is another

Jump to solution

I suspect this is another instance of an unfortunate regression introduced in PSXE 2017 Update 2 with the /debug-parameters option. I noted the case here also involves the debug build with /debug-parameters:used

Try disabling this option under the IDE: Properties > Fortran > Debugging > Information for PARAMETER Constants set to None

Let us know whether doing that helps work around the internal compiler errors.

View solution in original post

0 Kudos
Highlighted
New Contributor III

Hi Kevin,

Jump to solution

Hi Kevin,

thanks for the quick reply. You're absolutely right. Removing /debug-parameters:used from the options did the trick.

Still, I'm a little bit puzzled, because I use this option in other projects without getting an ICE, but I'm not completely sure whether I cleaned and rebuilt...

0 Kudos
Highlighted
Employee

It occurs in combination with

Jump to solution

It occurs in combination with the option use and some Fortran PARAMETER usage. One example is here. In the absence of the related Fortran usage you likely won't trigger the internal error with the option enabled.

(Internal tracking id: DPD200418283)

(Resolution Update on 05/12/2017): This defect is fixed in the Intel® Parallel Studio XE 2017 Update 4 release (ifort Version 17.0.4.210 Build 20170428 - PSXE 2017.4.051 / CnL 2017.4.210 - Windows)

0 Kudos
Highlighted
Employee

The fix for this issue is

Jump to solution

The fix for this issue is available in the latest PSXE 2017 Update 4 release.

0 Kudos