Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26757 Discussions

ICE with Intel Visual Fortran 2017, update 2

Arjen_Markus
Valued Contributor III
79 Views

Hello,

we are experiencing an ICE on a fairly large project when using Intel Visual Fortran 2017, update 2. This happens in debug mode but not in release mode. It also doesn't happen with earlier versions of the compiler:

6>readBoundaries.f90
6>D:\Scratch\ds-error\utils\flow1d\packages\flow1d_io\src\readBoundaries.f90(406): remark #7712: This variable has not been used.   [LVL]
6>fortcom: Fatal: There has been an internal compiler error (C0000005).
6>compilation aborted for D:\Scratch\ds-error\utils\flow1d\packages\flow1d_io\src\readBoundaries.f90 (code 1)
6>
6>Build log written to  "file://D:\Scratch\ds-error\utils\flow1d\packages\flow1d_io\x64\Debug\BuildLog.htm"
6>flow1d_io - 1 error(s), 0 warning(s)

I can supply the source code and project files that should enable you to reproduce it. However, we have not had the opportunity to trim it down to the barest example, as that might requires substantial code changes (because of dependencies) and the ICE might simply vanish without a trace.

0 Kudos
2 Replies
Lorri_M_Intel
Employee
79 Views

Hi Arjen -

          Do you have /debug_parameters set?  This is set by default in the DEBUG configuration.  There is a known problem with 17.0 that results in an internal compiler error for some sorts of parameters when we create the debug information.

          Kevin has written instructions for how to turn off the switch (it's one of the "sticky notes" at the top of the forum), and the bug should be fixed in the next update.

                   Thank you for your patience --

                                   --Lorri

Arjen_Markus
Valued Contributor III
79 Views

Hi Lorri,

that was spot on :). I had seen various discussions about it, but I had not realised that we were using it in this particular project. Turning it off made the ICE disappear.

Thanks very much for this quick solution.

 

Reply