Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner

IFORT.EXE not found when using USEENV flag

I am attempting to compile a .VFPROJ file inside of Visual Studio Ultimate 2013 Update 4. When I run VS2013 by typing DEVENV and then build the project, it builds without issue. However, when I run VS2013 by typing DEVENV /USEENV and then build the project, it errors out and says, "The Fortran compiler (ifort.exe) cannot be found." That doesn't make much sense. USEENV brings in the PATH, LIB, and INCLUDE environment variables to use in that session of VS2013. In Solution Explorer, I can click on the Property Manager tab, double-click "Release | x64" (which is the configuration I want), and then click VC++ Environment Variables to see those environment variables I pulled in using USEENV. They all show up as expected. And the second directory listed in my PATH (C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.2.187\windows\bin\intel64) is the exact directory that holds the version of IFORT.EXE that I want. Nonetheless, the build fails every time and IFORT.EXE cannot be located. Because of the software that our vendor provides, we have to build using DEVENV /USEENV. Any help would be appreciated!

0 Kudos
11 Replies
Highlighted
Moderator

Hello,

Hello,

Please check this discussion for suggestions:

https://software.intel.com/en-us/forums/intel-visual-fortran-compiler-for-windows/topic/644879

Devorah - Intel® Developer Support
0 Kudos
Highlighted
Beginner

Unfortunately, none of those

Unfortunately, none of those suggestions worked.

0 Kudos
Highlighted
Black Belt

I can reproduce this in

I can reproduce this in VS2017 and the beta 18 compiler. I know it used to work.

Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Beginner

We downgraded from IFORT

We downgraded from IFORT_COMPILER17 to IFORT_COMPILER15. That solved the problem. Apparently, IFORT_COMPILER17 doesn't play well with Visual Studio 2013 when the /USEENV flag is passed. Save yourself the frustration and go with IFORT_COMPILER15 when working with VS2013.

0 Kudos
Highlighted
Black Belt

This is clearly a bug -

This is clearly a bug - please report it through the Intel Service Portal. It is very easy to reproduce.

Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Beginner

Where is that located?

Where is that located?

0 Kudos
Highlighted
Black Belt

http://www.intel.com

http://www.intel.com/supporttickets

Or at the top of this forum, click Tech Support and then Individual Support.

Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Beginner

Won't let me do it.

Won't let me do it.

When I click that link (even when I'm logged in), it takes me to a page where it wants me to enter my personal info (last name, first name, email, user name, etc.). Most of those fields are disabled and I can't hit Next (it's grayed out) unless they're filled out.

If I try to get around that by clicking My Intel -> Edit Personal Information, it allows me to enter fields......but after about 5-10 seconds, the screen goes to a charcoal background color and a spinning icon spins endlessly......so I can't go back and enter the fields.

0 Kudos
Highlighted
Black Belt

Ok - I submitted it for you

Ok - I submitted it for you as #02957458.

Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Beginner

Thanks!

Thanks!

0 Kudos
Highlighted
Moderator

Steve, thank you very much

Steve, thank you very much for submitting this ticket!

Erik, I will contact you in PM regarding your account for Online Service Center.

Devorah - Intel® Developer Support
0 Kudos