Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26749 Discussions

Integration failure between Parallel Studio XE 2017 Update 4 Cluster Ed. and VS Community 2017

Manuel_Matias_M_
Beginner
116 Views

Hello,

I have installed  VS Community 2017 and  Parallel Studio XE 2017 Update 4 Cluster Ed. 

No problems on the installation (except   before I realize that I need also  Desktop development with C++ component.)

I have a program on Fortran. So, I create a project (Create a Project from existing Fortran code. Then two options:

1) If I compile without adding files, when I run the program (debug), It cannot find the project. 

2) If I compile adding all files, when I run the program, it says it cannot find rc.exe not found

Any suggestions?

Thanks!

0 Kudos
6 Replies
Manuel_Matias_M_
Beginner
116 Views

I am new at Fortran, so silly mistakes might apply

Steve_Lionel
Black Belt Retired Employee
116 Views

Did you in fact select "Desktop Development with C++ from the VS2017 install? If not, run the VS installer again and select this from the first page. I ran through this exact scenario just a few days ago.

Manuel_Matias_M_
Beginner
116 Views

I uninstalled both VS Community 2017 and PSXE Cluster update 4. I installed VS with "Desktop Development with C++ from first installation page. I then installed PSXE. Still I'm having the same problem.... rc.exe not found.

Additionally, I create the project using x64 or using the default x86 and then using the configuration manager. 

Steve_Lionel
Black Belt Retired Employee
116 Views

Search your C disk for rc.exe. If you properly installed VS2017 you should find one copy in a folder with a name similar to:

C:\Program Files (x86)\Windows Kits\10\bin\10.0.15063.0\x86

and one in:

C:\Program Files (x86)\Windows Kits\10\bin\10.0.15063.0\x64

Add the path you find to Tools > Options > Intel Compilers and Tools > Visual Fortran > Compilers > Executables. Add the x86 path to the list under Win32, and the x64 path to the list under x64.

Manuel_Matias_M_
Beginner
116 Views

I did it and it works. 

Then, I got problems with ifort.exe. Following the same idea, I added the path

C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.4.210\windows\bin\ia32 (Win32)

and 
C:\Program Files (x86)\IntelSWTools\compilers_and_libraries_2017.4.210\windows\bin\intel64

and works. 

After that, I got the error  #10037: could not find 'link'. Following intructions in other post, I rename C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC to
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VCX.....but stll gave me the same error.

Thanks for all the help!

Steve_Lionel
Black Belt Retired Employee
116 Views

You absolutely should not be adding Intel paths, nor renaming VS folders. My advice at this point is to uninstall Intel Parallel Studio, uninstall VS,  and start from the beginning. Make sure that you select C++ Desktop Development in the VS install.

Reply