Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
27432 Discussions

Intel* Fortran Compiler in oneAPI can not detect my visual studio 2019 wihle installing

Sean4
Novice
738 Views

while i install oneAPI to use Fortran it warning. $~_WQND2[U)N43QLNTF~0YX.png

Intel* Fortran Compiler (Beta) & Intel* Fortran Compiler Classic will not work because none of the supported environments is found on yourcomputer.
Intel" Fortran Co mpiler (Beta) & Intel* Fortran Compiler Classic requires that Microsoft Visual Studio* 2017 or 2019 should be already installedand none was found on your computer.

But I do got a VS2019(the latest version).

If I continue to finish the installment the Fortran won't appear in VS2019 as an option.

Y3RQFC78XOPT`YF5ORW@[AU.png

And I don't know if it's related, I didn't use the default path while install VS2019 because I don't got that much space in my c:\ .

I have tried the following but they won't work.

1.repair my VS2019;

2.repair my oneAPI.

What shoud I do? NEED YOUR HELP!THANKS

0 Kudos
1 Solution
Sean4
Novice
596 Views

Thanks to all friends above and sorry for not reply intime. Finally I've solve the problem by reinstall the VS2019 to C:\ .

I think it was because that at first I install the VS2019 in C:\ but my C:\ got no place after install it. So I remove the VS2019 so that my C:\ can have enough space to work. But the remove was not that thorough. It left some packege about VS2019. Then after I reinstall my VS2019 to D:\, the oneAPI still check my VS's existence in C:\ where only left a bunch of empty package. So the oneAPI keep warning me that.

Thanks for all your idea again.

View solution in original post

4 Replies
mecej4
Black Belt
686 Views

Did you request the VS2019 installer to install the "optional" components needed for compiling C/C++?

Can you compile, link and run a C "Hello World" or other short program, either from VS or the command line? These VIsual C tools (linker, libraries, etc.) are prerequisites for installing Intel Fortran.

I routinely install Intel Fortran and VS in a directory of my choosing, and have never run into a problem because of that choice.

Sean4
Novice
592 Views

Thanks for your advice. What your mentioned is part of the reason too, I didn't select the C++/CLI surpport for v142 generation tool. Without that I cann't use the Fortran eventhough I reinstall my VS2019 to C:\.

Sean4
Novice
597 Views

Thanks to all friends above and sorry for not reply intime. Finally I've solve the problem by reinstall the VS2019 to C:\ .

I think it was because that at first I install the VS2019 in C:\ but my C:\ got no place after install it. So I remove the VS2019 so that my C:\ can have enough space to work. But the remove was not that thorough. It left some packege about VS2019. Then after I reinstall my VS2019 to D:\, the oneAPI still check my VS's existence in C:\ where only left a bunch of empty package. So the oneAPI keep warning me that.

Thanks for all your idea again.

Reply