Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
27525 Discussions

How do I download an older version of the Intel Fortran Compiler?

AndrewOng
Beginner
270 Views

Good day!

 

I am currently trying to compile and run simulation software that seems to require an older version of the Intel Fortran Compiler. I constantly see something along the lines of "PRJ0018 following environment variables not found IFORT17." I would like to ask where I could possibly download an older version of the compiler.

 

Thank you!

0 Kudos
2 Replies
andrew_4619
Honored Contributor II
256 Views

there are so many old threads on the same topic such as https://community.intel.com/t5/Intel-Fortran-Compiler/Older-version-of-Intel-Fortran-Compiler/td-p/1...  for example

 

Steve_Lionel
Black Belt Retired Employee
244 Views

However... that particular error message doesn't mean you need an older version. Instead, it says that the project properties are referencing an IFORT17 environment variable, which is used to locate the compiler and libraries.  You'd need to find where this is being specified (as "$(IFORT17)") and change it to $(IFORT_COMPILER21) (assumes you have the latest version.

If you can attach a ZIP with the .vfproj file and the buildlog.htm from the Debug or Release folder, I can tell you where to look.

Reply