Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!

Internal compiler error

acar
Beginner
536 Views

Dear All,

I am getting a similar compiler error:

fortcom: Fatal: There has been an internal compiler error (C0000005).

But as I am using the latest compiler:

Compiling with Intel(R) Visual Fortran Compiler 17.0.2.187 [IA-32]...

I am guessing that this issue has not yet been resolved?

I have attached the problem file and would be grateful for any advice.

Thanks,  Angus.

0 Kudos
1 Solution
Kevin_D_Intel
Employee
536 Views

There is not an compilation ordering problem. As the compilation proceeds it suffers this internal error compiler error first for mouse_dialog.f90:

fortcom: Fatal: There has been an internal compiler error (C0000005).
ifort: error #10298: problem during post processing of parallel object compilation
compilation aborted for C:\RMA\Programs\EFE_V1.0\EFE\efe_gino\efe_mouse\mouse_dialog.f90 (code 1)

This compilation having failed likely would cause additional compilation errors downstream, which it appears it does.

I also see two additional internal compiler errors later in the build log for properties_group_module.f90 and mp_class.f90.

I can't say whether all three share the same underlying root cause or whether all three have a distinct root cause. Noting this is your debug build, you may be experiencing the internal error others reported earlier when using /debug-parameters:all.

Try disabling this option under the IDE: Properties > Fortran > Debugging > Information for PARAMETER Constants set to None

If you can compile without this option, then you can consider using this as a work around. If you still suffer one or more internal compiler errors then we would appreciate if we could obtain a reproducer to investigate and fix the underlying defect.

View solution in original post

10 Replies
Kevin_D_Intel
Employee
536 Views

I moved your post to a separate thread given the other thread has a resolution in PSXE 2017 Update 1 and while there's commonality in the "internal error" message issued, the two cases likely do not share the same underlying root cause.

To check whether the underlying root cause in your case is known or not, we need a complete preferably small reproducer. The attached test case requires many modules that were not provided. Are you able to supplement the test case any to eliminate the module dependencies or provide the source for the modules?

acar
Beginner
536 Views

Thanks Kevin.

I agree that it would be good to find a small reproducer but before doing this I wonder if you could take a look at the attached buildlog file.  This application built cleanly in my previous version of intel fortran (I think it was about 2013).  But now it seems that it does not get the compile order correct - errors are caused when module files are requested which have not yet been compiled.  If I then compile that particular module it gets a little further.  This is not what I was experiencing previously and after cleaning the project I would get a nice clean build.  

Thanks again for your help with this.

Angus.

andrew_4619
Honored Contributor I
536 Views

Does mouse_dialog.f90 contain any modules? This failed to compile with an ICE and is the first error. All the un-found modules then follow.....

Kevin_D_Intel
Employee
537 Views

There is not an compilation ordering problem. As the compilation proceeds it suffers this internal error compiler error first for mouse_dialog.f90:

fortcom: Fatal: There has been an internal compiler error (C0000005).
ifort: error #10298: problem during post processing of parallel object compilation
compilation aborted for C:\RMA\Programs\EFE_V1.0\EFE\efe_gino\efe_mouse\mouse_dialog.f90 (code 1)

This compilation having failed likely would cause additional compilation errors downstream, which it appears it does.

I also see two additional internal compiler errors later in the build log for properties_group_module.f90 and mp_class.f90.

I can't say whether all three share the same underlying root cause or whether all three have a distinct root cause. Noting this is your debug build, you may be experiencing the internal error others reported earlier when using /debug-parameters:all.

Try disabling this option under the IDE: Properties > Fortran > Debugging > Information for PARAMETER Constants set to None

If you can compile without this option, then you can consider using this as a work around. If you still suffer one or more internal compiler errors then we would appreciate if we could obtain a reproducer to investigate and fix the underlying defect.

View solution in original post

acar
Beginner
536 Views

Thank you both Andrew and Kevin.  I did as suggested by Kevin and all is now fine and the project compiles.  Many thanks for your time and help with this,  Angus. 

Kevin_D_Intel
Employee
536 Views

I'm glad to hear the work around helped. Our apologies for the regression. I added your instance to our internal tracking id and will notify you on the availability of a fix in a future update.

(Internal tracking id: DPD200418283)

(Resolution Update on 05/12/2017): This defect is fixed in the Intel® Parallel Studio XE 2017 Update 4 release (ifort Version 17.0.4.210 Build 20170428 - PSXE 2017.4.051 / CnL 2017.4.210 - Windows)

Kevin_D_Intel
Employee
536 Views

The fix for this issue is available in the latest PSXE 2017 Update 4 release.

elmar_strittmatterch
536 Views

Is it really fixed?!

I have to use the /debug-parameters:none option with the ifort 17.0.4.210 [IA-32], otherwise I still get the internal compiler error (C0000005).

Kevin_D_Intel
Employee
536 Views

Yes. I confirmed it is with the test cases others provided. If you can provide us with a reproducing test case then we will investigate your case. Perhaps you are seeing a variant or different issue not exposed by the earlier reproducers we received.

Kevin_D_Intel
Employee
536 Views

@elmar.strittmatterch.abb.com - there is another variant that was not covered, see here. Perhaps the character constant parameter relates to your case.

Reply