Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
27153 Discussions

LINK : fatal error LNK1104: cannot open file 'ifconsol.lib'

RoslynP
Novice
713 Views

I am using Parallel Studio XE 2020 Professional Edition, VS2017, and CMake. 

There are a few errors I am getting and I have tried to uninstall and reinstall all of my programs to see if it will fix it the problem. 

 

The main error is:

-- The Fortran compiler identification is unknown
CMake Error at Lib/Fast_Table/CMakeLists.txt:2 (project):
No CMAKE_Fortran_COMPILER could be found.

 

And in the error logs these errors are shown:

Package 'IFLangServicePackage' failed to load.

LINK : fatal error LNK1104: cannot open file 'ifconsol.lib'

 

All the paths seem to be correct and pointing to the correct locations but I can't seem to solve this error with any of the solutions I have tried online (there are not many).  Attached is the main error that is shown in the output. 

 

Thank you and let me know if this is enough information!!

0 Kudos
1 Solution
RoslynP
Novice
640 Views

Turns out that my installations of VS2017 and Intel Fortran were not setting up correctly. I had to go to the Intel Fortran solution under the folder in my build directory under .\CMakeFiles\3.18.4\CompilerIdFortran. Then I opened the project in Visual Studio. Tools >> Options >> Intel Compilers and Tools >> Visual Fortran >> Compilers. Then I went to the x64 tab and instead of having "Latest" selected, I selected "Intel(R) Visual Fortran Compiler 19.1.0.166 [Intel(R) 64]" and this had the proper setup for compiling Fortran. There were also some files in the 2020 compilers_and_libraries dir that were not in the 2020.0.166 dir.

I hope that helps someone in the future if they have this specific error.

View solution in original post

3 Replies
Steve_Lionel
Black Belt Retired Employee
698 Views

I'd guess that you don't have the Intel compiler environment established from the command prompt. It sets a number of environment variables, including LIB which is the critical one here.

RoslynP
Novice
654 Views

I've tried to set up the environment from the command prompt with no success. The error still occurs. The Path for VS2017 seems to be correct along with the environment paths that I have established. I didn't know if it was a linking error or something to do with CMake, Intel Fortran and VS2017 not working together as they should. I've tried to uninstall and reinstall all of them  as well. 

RoslynP
Novice
641 Views

Turns out that my installations of VS2017 and Intel Fortran were not setting up correctly. I had to go to the Intel Fortran solution under the folder in my build directory under .\CMakeFiles\3.18.4\CompilerIdFortran. Then I opened the project in Visual Studio. Tools >> Options >> Intel Compilers and Tools >> Visual Fortran >> Compilers. Then I went to the x64 tab and instead of having "Latest" selected, I selected "Intel(R) Visual Fortran Compiler 19.1.0.166 [Intel(R) 64]" and this had the proper setup for compiling Fortran. There were also some files in the 2020 compilers_and_libraries dir that were not in the 2020.0.166 dir.

I hope that helps someone in the future if they have this specific error.

Reply