Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.

Linker warning that won't go away

Deleted_U_Intel
Employee
203 Views
I am using the Digital Visual Fortran Professional Edition for all of my programming needs. Currently, I am doing Agent Based Modeling, a type of social simulation modeling. I have written a lot of code that works fine but I have been having trouble using a library of subroutines that I typed out from Numerical Recipes a number years ago. Those subroutines are all written in F77, but they work just fine when I pull them into a project as source code.
Because that is not efficient, I have decided to put them into a library. But when I pull the library into the program via the "Project --- add files---" route, followed by compiling and linking, I get the linker warning shown below. Though the program seems to run correctly, I am uncomfortable with this situation.
Any thoughts on how to eliminate this warning? Please be detailed as I sometimes find the DVF documentation insufficient.
Thank you!
LINK : warning LNK4098: defaultlib "libcd.lib" conflicts with use of other libs; use /NODEFAULTLIB:library
John
0 Kudos
1 Reply
Jugoslav_Dujic
Valued Contributor II
203 Views

Go to Project/Settings/Fortran/Libraries category for your .lib file and check "Disable default library search rules". Then rebuild the library & the calling exe.

See this threadand especially the MCLS link therein for an explanation.
Jugoslav
0 Kudos
Reply