Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
27228 Discussions

MSVC2017 debugger does not recognize lowercase letter in FORTRAN code

calinex
Beginner
714 Views

Hi,

I recently upgraded to Intel Parallel Studio 2020U4 (FORTRAN), which installed the IDE into MSVC 2017.

 

Unfortunately, when debugging FORTRAN code, MSVC reports variables written in lowercase as undefined. I have to write them manually in the watch window in uppercase in order to see their value.

 

Earlier combinations of ifort+MSVC are working fine on the same binaries, in the sense that the debugger is case insensitive.     

 

Did someone encounter this problem? Can I instruct the MSVC FORTRAN IDE to be case insensitive?    

 

Thanks,

-calinex

0 Kudos
1 Solution
Steve_Lionel
Black Belt Retired Employee
605 Views

Glad to hear it. Please mark my response as the "solution" to help others.

View solution in original post

9 Replies
Steve_Lionel
Black Belt Retired Employee
705 Views

The problem you have is that you're using the C debugger and not Fortran. Usually an uninstall and reinstall of the Intel product fixes this.

calinex
Beginner
692 Views

Thanks Steve, this was my thought as well. Uninstall and reinstall did not solve it. It was a fresh installation of both, MSVC and Intel, anyway. 

There must be a setting somewhere, or at least this is my (only) hope.

If I open the Locals window, I can see all the variables in uppercase along with their values. I assume that this is because the symbols are written in the binaries in uppercase. What bothers me is that it used to work fine in MSVC2016, where I was able to see them as they are written in the code (mostly lowercase). Unfortunately, when the XE Composer installs, it removes the support for MSVC2016 and installs the one for MSVC2017. 

 

-calinex    

Steve_Lionel
Black Belt Retired Employee
678 Views

There is no setting. In the Locals window, do variables show as having Fortran type names (INTEGER, REAL, etc.) or C names (int, float, etc.)? Yes, the symbols are in the database as uppercase, but the Fortran Expression Evaluator is case-blind.

This problem has hit many before, it can always be resolved. 

At this point I would suggest installing the latest oneAPI product, which is free. You will need only the oneAPI HPC Toolkit, unless you also want MKL, in which case you will also need the Base Toolkit. You can customize the install to get just Fortran and not the other Intel tools it installs Visual Studio 2017 is supported.

After installing this, also install the Fortran Runtime components which are now packaged separately.

calinex
Beginner
672 Views

Thanks Steve for further explaining this issue.

In the Locals, the FORTRAN variables appear as C, like float, long, etc.

I will try installing oneAPI and the runtime components. 

 

Best,

-calinex

Steve_Lionel
Black Belt Retired Employee
667 Views

That tells me that the Fortran expression evaluator is not being recognized. Try the oneAPI install.

calinex
Beginner
617 Views

Installing "Desktop development with C++" component in VS2019 and then reinstalling ifort2020U4 solved the issue. 

 

Thanks Steve for your valuable support.

 

-calinex 

Steve_Lionel
Black Belt Retired Employee
606 Views

Glad to hear it. Please mark my response as the "solution" to help others.

dajum
Novice
566 Views

Steve the link to the runtime components in your post above is the same as the link to OneAPI.  I don't see the runtimes here.  can you fix the link?

Steve_Lionel
Black Belt Retired Employee
544 Views

Sorry about that. Correct link is Intel® oneAPI standalone component installation files

Unfortunately, I can no longer edit the earlier post.

Reply