Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1 View

Need Older version of Visual Fortran Composer XE

I need an older version of Visual Fortran Composer XE.  Must be 2016 or prior (Compiler Version 16.0) to be compatible with Visual Studio 2010.  Can you please provide link for purchase/download?

0 Kudos
6 Replies
Highlighted
Moderator
1 View

This page describes which

This page describes which Intel compilers are currently available to download.  The oldest is PSXE 2017.

Visual Studio 2010 is quite old!

 

0 Kudos
Highlighted
Black Belt
1 View

In nearly all cases., you don

In nearly all cases., you don't "need" an old version - the current version will work well or even better, but may take some one-time effort to configure a third-party tool to find the compiler.

Why do you think you need such an old compiler (and VS)?

Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
New Contributor I
1 View

Very sad to see that only a 3

Very sad to see that only a 3 years old IVF compiler is still supported. Compare with Visual studio 2017 is planned to be supported until 2027.

See: https://docs.microsoft.com/en-us/visualstudio/releases/2019/servicing

Intel should provide a similar information. Professional developing large application should have such an information in advance.

Best regards

 

0 Kudos
Highlighted
Black Belt
1 View

https://software.intel.com/en

https://software.intel.com/en-us/articles/intel-parallel-studio-xe-supported-and-unsupported-product...

Intel's policy for "support" has generally been current version and previous two, though updates stop once a new major version is released (except in very narrow circumstances.) Of course, once you have installed a particular version, it continues to work indefinitely. 

Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos
Highlighted
Beginner
1 View

Quote:Steve Lionel (Ret.)

Steve Lionel (Ret.) (Blackbelt) wrote:

In nearly all cases., you don't "need" an old version - the current version will work well or even better, but may take some one-time effort to configure a third-party tool to find the compiler.

Why do you think you need such an old compiler (and VS)?

 

So the compilers in Intel Parallel Studio XE 2020 are compatible with Visual Studio 2010?

 

0 Kudos
Highlighted
Black Belt
1 View

No, but VS2010 is no longer

No, but VS2010 is no longer supported by Microsoft. You can use the Intel compiler with Visual Studio 2019 Community Edition, if you need a free version of VS.

Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos