Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.

Older Compiler Download Information

Ron_Green
Moderator
4,635 Views

A common question we see on this Forum is 'where can I download version ##.#.###?'.  

First, if you think you need a specific, older version of the compilers you are probably mistaken.  Perhaps you are using a library or simulation framework and the vendor has a System Requirements that call out a specific version of the Intel compilers.  Unfortunately many software vendors are slow to update their System Requirements for the latest compilers.  In fact, many list compilers that we no longer officially support.

In 99.9% of cases, you can use the latest Intel compilers with any vendor library or framework.  Intel has not changed our binary formats or ABI - Application Binary Interface for many many years.  In other words, our newest compilers produce DLLs or shared libraries, object files, executables that are backwards compatible to older Intel Fortran versions.  One caveat is that many frameworks have setup scripts or files that set environment to find the compiler and compiler libraries - these PATHs and other env setting and setup files are different between Intel(R) Parallel Studio XE and Intel oneAPI packages.  Contact your vendor for information on Intel oneAPI Compiler support.

 

So if you read the above and still think you need an older version of the compilers:

  • You can read the FAQs for information such as where to download older versions along with many other common questions.
  • You can read our Older Version Download information
  • Downloads are limited to Supported Versions, not all past versions are available.
  • To get access to older version downloads you will need to have an active Priority Support license. 
  • Free Downloads: Only the latest version of Intel Fortran is available for free download and use. 
  • For compatibility with CVF or DVF, see the /iface compiler option
1 Solution
Steve_Lionel
Black Belt Retired Employee
1,301 Views

Do you have active support? If so, then older versions are available from https://registrationcenter.intel.com/  If you don't have active support, then no.

View solution in original post

25 Replies
Khizar
Beginner
4,175 Views

Hi there,

 

Hi, 

 

I am using an older version of the MS Visual Studio (2010) and intel fortran compiler (2016) to compile make an executable from the user defined code. I successfully compiled the code and was in the process of de-bugging; however, the evaluation period has ended that was 30 days. Now, I get the following error when I try to compile:

"error #10052: could not checkout FLEXlm license"   

 

I was wondering how I can obtain license?

 

Any help will be greatly appreciated.

 

Thanks,

Khizar

error #10052: could not checkout FLEXlm license

andrew_4619
Honored Contributor II
4,158 Views

The latest version are free, you don't need a licence. Why use such old versions?

 

Khizar
Beginner
4,117 Views

I have tried the latest version (MS visual studio 2022, Intel API), but I get the following error:

 

"libcpmt.lib(cout.obj) : error LNK2038: mismatch detected for '_MSC_VER': value '1900' doesn't match value '1600' in libdyna.lib(IntRules_CFunc.obj)"

 

For my work, the sources files and object files were provided by a commercial software company. These files were compiled by using the old MS visual studio and intel Fortran; therefore, when I use the new version to compile my code with these files, I get above error. Any help will be appreciated.  

Steve_Lionel
Black Belt Retired Employee
4,114 Views

If this is for work, an evaluation license is not appropriate. You can purchase support from Intel, which will give you access to some older versions. But the library you're linking to was built with VS2010. No available version of Intel Fortran supports VS2010. This error, by the way, is related entirely to Microsoft Visual C++, not Intel Fortran.

Khizar
Beginner
4,112 Views

The "Readme" file specifies to use particular versions of Intel and MS visual C++. When I was using the older versions, I was compiling successfully. As I switched to the new versions, the error was generated. Any idea how I can solve the above error? This is for my research work.

Ron_Green
Moderator
4,089 Views

I would guess 'libdyna.lib' is a 3rd party lib.  Is this DYNA 3D maybe?

So you have an ancient version of DYNA or some other library file, and you're trying to use this library.  Maybe because you don't want to get the latest version of this library? 

 

As Steve said, even IF you purchase a support contract, the oldest compiler you can get is version 19.0.  See THIS PAGE for supported and unsupported versions.  

Ron_Green
Moderator
4,086 Views

Khizar, I will move this post over to our Startup page.  Please have your serial number, license file, or the userID or email for the person who is the registered owner of your old 2016 compiler.  If you don't have that, we can't help you.

Khizar
Beginner
4,066 Views

Hi Ron_Green,

 

I contacted the Intel support but could not get the license for the older versions. Therefore, I planned to try to compile codes using the newer versions. I tried compiling with the MS visual studio 2017 and Intel Fortran compiler 2022, but I am getting the following error:

"\implicit2.inc(7): error #7614: A common block name may appear in an OpenMP THREADPRIVATE directive only after the last COMMON statement which specifies the same common block name. [BKI03ILOC]
common/bki03iloc/lnodim(nlq,48),ndofpn,nnpke,melemt,imlft,imllt," 

 

Any idea how to fix this?

 

Thanks,

Khizar

IanH
Black Belt
4,046 Views

This is a restriction straight out of the OMP standard.

You could simply move the threadprivate directive.

Khizar
Beginner
4,033 Views

Thanks. I am getting this error when I compile the source code provided by LS DYNA (without adding my own code) with the latest compiler. I was not getting this error when using the trial version of the old compiler. The source code provided is huge and consists of several files. I m not sure where I should change exactly for this error ""\implicit2.inc(7): error #7614: A common block name may appear in an OpenMP THREADPRIVATE directive only after the last COMMON statement which specifies the same common block name. [BKI03ILOC]
common/bki03iloc/lnodim(nlq,48),ndofpn,nnpke,melemt,imlft,imllt,""?  

Khizar
Beginner
4,025 Views

Another error that I am getting is as:

 

"dyn21ushl.F(2572): error #7881: This module file was generated for a different platform or by an incompatible compiler or compiler release. It cannot be read. [USERINTERFACE]
use userinterface"

 

Can you please tell me how to fix the above error. It says compiler incompatible.

mecej4
Black Belt
4,019 Views

Almost none of us has access to the proprietary source code that you are attempting to compile, and you should not expect us to tell you what to fix based on just the error message and the single line of code that it corresponds to. 

Searching the web leads to a page that may pertain. Using a couple of lines of source code near the bottom of that page, I constructed the following program unit.

      subroutine xyz
      integer, parameter :: nlq = 6
      common/bki03iloc/lnodim(nlq,48),ndofpn,nnpke,melemt,imlft,imllt,
     &                 is17loc,is18loc,imp_mxe
c$omp threadprivate (/bki03iloc/)
      print *,nnpke
      return
      end subroutine

Compiling this with the command ifort /Qopenmp /c xyz.f produced an OBJ file and no error messages.

 

The error message that you quoted in your latest post is probably the result of (i) compiling and generating the module file using an old version of the compiler and (ii) attempting to compile a source file that USEs that module, using a much more recent version of the compiler. The remedy is to delete all module and OBJ files that you generated from sources using the older compiler, and rebuilding.

Ron_Green
Moderator
4,013 Views

OpenMP error:  you probably have the OMP directive above your include implicit2.inc.  Or look in implicit2.inc.  Newer compilers are better at catching illegal code   you will need to fix your code.

 

but your BIG issue is you have a very old LS DYNA.  And you're trying to make it work with a new compiler that does not recognize the .mod files provided by DYNA.  Either they are for another compiler, like Lahey, Absoft, or PGI or gfortran or some other non-Intel Fortran.  OR they are just so old that our compiler cannot work with them.  


My conclusion - you either work with the Startup and Licensing team here to get an old PSXE license so you can use your very old Intel compiler  with the very old LS DYNA - OR you pay LS DYNA for a new and up to date version of DYNA that will work with the modern compiler and a modern version of Windows.   But you do need to look at the include for implicit2.inc relative to where you put the OMP directive.  This is why include files are generally a very bad coding practice.

Khizar
Beginner
4,007 Views

Thanks @Ron_Green for the suggestions. I contacted both Intel and LS DYNA in the past for this issue, but was not of much help. Anyways, I have been able to fix that error by changing C_TASKCOMMON to c TASKCOMMON (took it from another source). I am going to further test it and hope it will work fine.

 

mecej4
Black Belt
3,998 Views

The TASKCOMMON parallelization directive is nonstandard. Its syntax in Sun Fortran is

 

C$PAR TASKCOMMON BKI03ILOC

 

Instead of this nonstandard directive, use the OpenMP THREADPRIVATE directive if you want portability.

Khizar
Beginner
3,977 Views

Hi,

 

I have been able to compile without any warning/error and create .exe; however, when I try to run it for my simulation I get the error "The ordinal 747 could not be located in the dynmaic library C:\LSDYNA........... " . 

 

I have moved the .dll files to the same folder where running, but not making any difference. Just wondering how it could be solved?

 

Thanks

Germán
New Contributor I
1,204 Views


"...if you think you need a specific, older version of the compilers you are probably mistaken."


Well, say what you will, but many of us are rather picky and get comfort and confidence out of knowing that we are using a specific version over and over, for as long as we can.

 

Historically, choice of compiler version is included in our makefiles as we have access to several versions of GFortran and a handful of Intel ones.

 

Early this year, I started a new project on the Windows parallel universe and downloaded the Fortran compiler available at the time; now, I would like to replicate my workflow on the Linux parallel universe, including the choice of compiler version...but no cigar.

 

I had previously downloaded the standalone Fortran from here.

 

Now, this page only shows the latest 2023 release and there does not seem to be a easy way to download a previous release. While the release notes continue to be available, the actual downloads are nowhere to be found.

 

So, if I could be spared arguments one way or another and simply get a couple of direct, honest answers, I would appreciate very much:

Are previous releases of the Fortran available? Yes | No
If Yes, where?

Thanks.

 

Steve_Lionel
Black Belt Retired Employee
1,302 Views

Do you have active support? If so, then older versions are available from https://registrationcenter.intel.com/  If you don't have active support, then no.

Stephen_Sutcliffe
New Contributor II
488 Views

What does this mean?

I have subscribed to premier support (or equilalent) since the days of Digital Fortran.

Stephen_Sutcliffe_0-1673878886908.png

I need to download a previous version as the latest (Dec 2023) has a regression which causes BACKSPACE to not function properly in IFORT & IFX. This matter has been raised by another user in another thread on this forum.

My subscription is due to expire until Nov 2023 so don't see why I need to pay for backdated renewal of retrospective peroids that I had already for continuously?

 

Reply