Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.

OpenMP

siemer_michael
Beginner
297 Views
HI,
how do I get openmp to work in xcode 3.1 ? I have the most recent intel fortran and it's running fine without openmp.
If I choose enable openMP support in the build settings I get the following error message:

dyld: Library not loaded: libiomp5.dylib

Referenced from: /Users/.../Library/Developer/Xcode/DerivedData/hello_world-gboojatjcgugwggnwsmnsuruvbam/Build/Products/Debug/hello world

Reason: image not found



thanks a lot.


Michael

0 Kudos
2 Replies
zuch
Beginner
297 Views
Hi Michael,
You need to setDYLD_LIBRARY_PATHenvironment variable in the Xcode environment.
You can find more details here
0 Kudos
siemer_michael
Beginner
297 Views
Thanks, after fixing that I still get the following error message:

sharedlibrary apply-load-rules all

Warning: the current language does not match this frame.

No memory available to program now: unsafe to call malloc

warning: Attempting to create USE_BLOCK_IN_FRAME variable with block that isn't in the frame.

warning: Attempting to create USE_BLOCK_IN_FRAME variable with block that isn't in the frame.

Current language: auto; currently fortran

Any ideas what to do about this one?

0 Kudos
Reply