Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.

Slow compilation

Stupak__Richard
Beginner
2,542 Views

Hi all,

I have some mixed language DLL (c++ & fortran). I am using WIN7 with VS2015 and Intel fortran compiler 2016, when i try to compile it, it takes like 1 minute for one fortran file. When i compile it on WinXP VS6 and visual compaq fortran it takes like 1m for whole DLL.

When i am compiling other applications (pure c++) it goes fine.

Do you have any idea if there is some problem in settings of intel fortran compiler??

Thanks

Richard

0 Kudos
24 Replies
Steven_L_Intel1
Employee
2,037 Views

Are you using a floating license or a "named user" license? We sometimes see with floating licenses that the license checkout takes a long time if there are problems with the network. Do you see a slow compile even for a Debug configuration or a simple "Hello World" type application?

0 Kudos
Stupak__Richard
Beginner
2,037 Views

Hi Steve,

I tried simple "Hello World" and it took like 10s to compile.

I got a serial number for my product, so i suppose its not floating license.

0 Kudos
Steven_L_Intel1
Employee
2,037 Views

Indeed you have a named-user license. Strange. Please look in the C:\Program Files (x86)\Common Files\Intel\Licenses folder - how many license files are there?

Do you see the same sort of delay if you compile Hello World from a command prompt?

0 Kudos
Stupak__Richard
Beginner
2,037 Views

I have there 5 *.lic files. 

I tried ifort but I get this:

"Intel(R) Visual Fortran Intel(R) 64 Compiler for applications running on Intel(R) 64, Version 16.0.2.180 Build 20160204
Copyright (C) 1985-2016 Intel Corporation.  All rights reserved.

ifort: error #10037: could not find 'link'"

0 Kudos
Steven_L_Intel1
Employee
2,037 Views

Did you use the command prompt shortcut we provide in the Start menu under Intel Parallel Studio XE 2016? Did it seem to take a long time to get to the last line?

I suggest you go through the .lic files and delete those that are not current. I show you as having one Fortran license.

0 Kudos
Johannes_Rieke
New Contributor III
2,037 Views

Hi Richard,

I had a similar problem with slow compilation time respectively some time lag before fortcom started. In my case I had two files in the 'C:\Program Files (x86)\Common Files\Intel\Licenses' folder. Although I renamed the old license file, this old license file caused the error. It contained a link to an old floating license server (USE SERVER ...). If only one license is active, maybe you can delete the others from the folder. If you need all, there is a very simple way described in documentation to combine all these license files into only one. Maybe this helps...

Regarding to the command line, you opened the console from the subfolder 'Command Prompt with Intel Compiler' in the 'Intel Parallel Studio XE ...' in the start menu?

Good luck, Johannes

edit: Steve was some minutes faster...

0 Kudos
Stupak__Richard
Beginner
2,037 Views

I deleted all licenses, just left the newest one ( i reinstaled parallel studio few days ago), but does not look like something changed.

I tried Start->All programs->Intel Paralell 2016..->Compiler and Performance lib->Command prompt with Intel.. -> All of them and got this:

Copyright (C) 1985-2016 Intel Corporation. All rights reserved.
Intel(R) Compiler 16.0 Update 2 (package 180)

ERROR: Cannot determine the location of the VS Common Tools folder.

 

0 Kudos
Steven_L_Intel1
Employee
2,037 Views

Richard, has your administrator restricted access to registry query tools? Can you run C:\Windows\regedit.exe ?

0 Kudos
Stupak__Richard
Beginner
2,037 Views

Yeah, i can run regedit.

0 Kudos
Steven_L_Intel1
Employee
2,037 Views

Which version and edition of Visual Studio do you have installed?

0 Kudos
Stupak__Richard
Beginner
2,037 Views

VS 2015 professional 14.0.24720.00 Update 1

0 Kudos
Steven_L_Intel1
Employee
2,037 Views

Ok. What happens when you open Start > All Programs > Visual Studio 2015 > Visual Studio Tools > Developer Command Prompt ?

0 Kudos
Stupak__Richard
Beginner
2,037 Views

The same like with fortran prompt.

0 Kudos
Steven_L_Intel1
Employee
2,037 Views

You get the message about can't locate common tools? That suggests that your Visual Studio install is mangled somehow. Try a "repair" on Visual Studio 2015 and then reinstall (or "repair") Intel Parallel Studio XE. You may want to install Visual Studio 2015 Update 2, but do this only if you don't use Intel C++ as VS2015 Update 2 broke that.

0 Kudos
Stupak__Richard
Beginner
2,037 Views

I tried repair on VS and then reinstalled Intel Parallel studio. 

I instaled VS update 2, but i still get same error in command line and no change in compilation time.

0 Kudos
Stupak__Richard
Beginner
2,037 Views

Ok i get rid of the Error from command line (Some problem with Path variable). But it takes too much time to compile only "hello world" app fortran file.

0 Kudos
Steven_L_Intel1
Employee
2,037 Views

Ok. Now please do this in the command prompt session. First, make sure you are in a writable folder not under Program Files.  Then do:

set INTEL_LMD_DEBUG=log.txt
ifort -c hello.f90

Where "hello.f90" is the name of your source. Use "Send author a message" to send me a private message and attach the log.txt file it creates.

0 Kudos
Steven_L_Intel1
Employee
2,037 Views

This was resolved. Richard's system had a definition for LM_LICENSE_FILE that pointed to some other system on his local network. The license check looks at all available licenses and checking this server was slow or timed out. Removing that definition restored Fortran compile performance. (I've asked Richard to make sure that no other product on his system needed that license definition.)

0 Kudos
Song__James
Beginner
2,037 Views

How do you remove the definition? 

0 Kudos
Song__James
Beginner
1,826 Views

On Linux this is very straightforward to do, but hey, winDOS ...

0 Kudos
Reply