Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner

System requirements infos

Hi,

I tried to install an old version of Intel suite: "Intel fortran compiler 11.1", but it reports some issues about kernel, glibc and binutils version. After that procedure just fails.

System glibc or kernel version not supported or not detectable.
Supported glibc/kernel versions:
architecture    kernel        glibc
IA-32          2.4           2.2.93, 2.3.2
IA-32          2.6           2.3, 2.4, 2.5, 2.6

And the following:

Binutils version not supported or not detectable.
Supported versions are greater than 2.13.

On the other hand on my system I have the following versions:

Arch: IA_32
Kernel: 3.19.4
glibc: 2.15
binutils: 2.22.52.0.2

Now I'd ask which version of "Intel suites" (containing ifort compiler) could be compatible with my system?

Eg.

Would "Parallel Studio XE 2016" work on my system? Or should I need an older Intel product? which one for example?

Thanks in advance,

Regards.

0 Kudos
7 Replies
Highlighted

The Release Notes have system

The Release Notes have system requirements. Looking at the 2016 release notes, it would seem that version would support your configuration. The release notes generally refer to distribution names and versions, though I do see gcc and binutils versions listed.

Retired 12/31/2016
0 Kudos
Highlighted
Beginner

Thanks for your reply Steve!

Thanks for your reply Steve!

So, relevant dependency software would be gcc and binutils version.
But does my system have to be equipped with exactly the same version reported by system requirements specs? Or should it work also with a more recent version of those dependencies?

Let's refer for example to old intel fortran compiler 11.1 version, could you help me to find the right release notes and system requirements it reports about binutils and gcc versions?

I started to look at this document:
https://software.intel.com/en-us/articles/intel-fortran-compiler-111-release-notes

But I can't find an explicit requirement for gcc version. It reports "Debian 4.0" as supported system. So I read the old debian 4 "Etch" release notes and which gcc version it contains:

https://wiki.debian.org/DebianEtch

kernel : linux 2.6.18
libc : libc6 2.2.3
gcc : 4.1.1

https://archive.debian.net/etch/devel/binutils

binutils 2.17-3


My system has gcc-4.7.1 version and other packages version reported in above message. All this version are more recent than the ones required... but installation failed.

In your opinion, is there some workaround to make 11.1 version working on my system or it is too old compared to my system installed package?

0 Kudos
Highlighted
Black Belt

g++ on path must match gcc.

g++ on path must match gcc. Fortran isn't likely to run into trouble with a newer gcc than the expected one. If you continue to have difficulty, please quote specific error messages.
0 Kudos
Highlighted
Beginner

​As I written above my system


​As I written above my system has gcc 4.7.1:

​$ g++ --version
g++ (GCC) 4.7.1
Copyright (C) 2012 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

I don't understand if this is supported by "intel fortran compiler 11.1".

If I skip requirements check and try to continue install process, It doesn't return any error messages, just creates empty folders on /opt/intel/Compiler, while I expected to find compiler and all other intel tools in that path...

0 Kudos
Highlighted
Beginner

Update: I can see an error

Update: I can see an error message, but ii doesn't add any details:

Step no: 6 of 7 | Installation
--------------------------------------------------------------------------------
Each component will be installed individually. If you cancel the installation,
components that have been completely installed will remain on your system. This
installation may take several minutes, depending on your system and the options
you selected. 
Installing, please wait...
--------------------------------------------------------------------------------
Installing Intel(R) Fortran Compiler for applications running on IA-32 
component...
Intel(R) Fortran Compiler for applications running on IA-32  component
installation failed.
--------------------------------------------------------------------------------
Press "Enter" key to continue

 

0 Kudos
Highlighted
Black Belt

There's an install log placed

There's an install log placed in $TMPDIR, but it tends to be difficult to interpret.  A possible reason for install quitting like this is there is already an entry in rpmdb or package manager left by a previous installation failure.  Guessing that your system isn't rpm based, I would suggest you check to see if something can be cleared in package manager.

32-bit installations became difficult in the 11.x series, and I didn't keep up with them, not knowing why anyone would continue to use them.  I suppose there are possible peculiarities in installation of old compilers on Debian style systems.

0 Kudos
Highlighted
Beginner

By reading that log I noticed

By reading that log I noticed there were some errors related to execution permissions of some internal scripts.

Eg.

/tmp/intel.pset.root.darkstar.example.org_04.11.00.00.06.2016.log

 

... /pset/rpm_extract.x32: Permission denied

So I tried to give execution permissions to all files contained in intel extracted package:

chmod -R +x  /path/to/l_cprof_p_11.1.073_ia32

Then I tried installation again. And now target directory /opt/intel/ contains expected files.

My distribution is Slackware. Package managment is very simple, there's no database, nor dependency facilities and so on.

As you can see the problem was a permission issue, probably caused by wrong umask when I copied/extracted installer package.

I think my reported issue is solved. Now I'll test a compile of my fortran source code and run executable it will create. Hope it works!

Thanks a lot for your replies!

0 Kudos