Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
16 Views

The Fortran compiler (ifort.exe) cannot be found

Greetings

In order to build Fortran programs, after installing Microsoft Visual Studio Community 2015, I installed the latest Intel Parallel Studio, Intel Parallel Studio XE 2016 Update 2 Cluster Edition for Windows.

Everything went fine during installation (except for some minor network problems during online installation) and the integration seemed OK, but whenever I try to start the sample code of Intel Visual Fortran (New Project/ Intel Visual Fortran/ Console Application/ Main Program Code/ Start), the following Error occurs:

"There were build errors. Would you like to continue and run the last successful build?"

and when I select "No", it says:

"The Fortran compiler (ifort.exe) cannot be found."

 

I have almost checked everything I could find on the internet.

In my "VFPackages" folder, there are four dll files (VFAVWin.dll, VFHieEditor.dll, VFProj.dll and VFProjConvert.dll), one bat file (integrate.bat) and two folders named as 1033 and 1041.

I also checked another installed language on Microsoft Visual Studio to check if the problem relates to the Visual Studio itself, but a simple program on Visual Basic Console Application worked perfectly fine!

As it was recommended by some websites, I checked the General options of Visual Fortran (Tools > Options > Intel Visual Fortran > General) and they were fine. There were .f;.for;.fpp and .f90 in the Fixed Form > Sources field and in in the Free Form > Sources field, respectively.

It was also recommended by some experts to uninstall and reinstall the Intel Parallel Studio. I try to avoid that for now (because it is time-consuming and costly!), but I tried to repair the product instead. It was supposed to "fix missing or corrupt files, shortcuts or registry entries" and perhaps fix the whole problem, but sadly nothing happened!

Now I don't have even a clue to solve this problem.

I would really appreciate if anyone could help me. Any suggestions are more than welcome.

 

By the way, I am using Windows 10 Pro (64 bit).

 

Regards

0 Kudos
6 Replies
Highlighted
16 Views

You probably did not choose

You probably did not choose to customize the VS2015 installation to add C++ support and didn't notice the warning from the Intel Parallel Studio XE install. Do a "Change" on VS2015, check the box for C++ language support, then reinstall Intel Parallel Studio XE.

Retired 12/31/2016
0 Kudos
Highlighted
Beginner
16 Views

Thank you Steve

Thank you Steve

I just want to be sure what exactly I have to do before I make any changes.

I tried to "change" VS2015 but in the features window, under "Programming Languages" branch, all options were already selected including Visual C++!! [Please see the snapshot]

Besides, I don't remember any warning from the Intel Parallel Studio XE during installation.

Capture.JPG

0 Kudos
Highlighted
16 Views

Hmm. Usually that's the cause

Hmm. Usually that's the cause of the compiler not being found.

I suggest uninstalling and then reinstalling Intel Parallel Studio XE and see if that resolves the problem.

Retired 12/31/2016
0 Kudos
Highlighted
Beginner
16 Views

Hello,

Hello,

I am using Visual Studio 2017 with Visual C++ (See "Visual Studio Info.txt")
I just installed Intel® Parallel Studio XE 2018 Composer Edition for Fortran Windows*   Package ID: w_comp_lib_2018.0.124

Compiling a simple "Hello World" program gives me the error "The Fortran compiler (ifort.exe) cannot be found".
Reinstallation doesn't fixed this problem
I saw however that in the Options tab (See "Options.JPG") the paths to the Executables, Includes and Libraries are correct.
When I changed these to $(IFortInstallDir).... it was still not working because during the installation the enviroment variable IFortInstallDir wasn't created. A variable IFORT_COMPILER18 is available.

The compilation now works with the warning:
ifort: remark #10421: The IA-32 target wrapper binary 'ifort' is deprecated.  Please use the compiler startup scripts or the proper Intel(R) 64 compiler binary with the '-Qm32' option to target the intended architecture
warning #31001: The dll for reading and writing the pdb (for example, mspdb110.dll) could  not be found on your path. This is usually a configuration error. Compilation will continue using /Z7 instead of /Zi, but expect a similar error when you link your program.

But the build is not working because of the error "rc.exe not found."

Is there anyone who can help with this
Aid Usman

0 Kudos
Highlighted
Valued Contributor II
16 Views

I had a similar problem after

I had a similar problem after an install last week and fixed it by:

"Tools > Options > Intel Compilers and tools > Compilers"  and clicking the "reset" button

0 Kudos
Highlighted
New Contributor II
16 Views

Thanks Andrew, I had the same

Thanks Andrew, I had the same problem and it is solved now!

Robert

 

0 Kudos