Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
164 Views

Unable to have .lib compiled

Hi !!

We have an old Fortran 6A source code in Italy.
We have visual studio 2013 installed on windows server 2008 R2 64 bit.

But.. We cannot compile Fortran... no error.. no .lib if I biuld a project ... !!!!!!!

If I try to build the solution I get some errors like this one :

Error    6    error LNK1181: cannot open input file 'C:\Users\RIDP425\Desktop\Ver_3.0.3.0_Marzo_2016\Fortran\prg\Lib_aux_curve\Debug\Lib_aux_curve.lib'    C:\Users\RIDP425\Desktop\Ver_3.0.3.0_Marzo_2016\Fortran\prg\main_analisi_statistica\LINK    main_analisi_statistica

I explain ->

We purchased intel composer 2016 version 2 and installed on visual studio 2013 update 5 .
We then loaded the solution with visual studio 2013 .
When I compile a basic project gives no error and gives us the build complete message but under the Debug folder does not appear any librart.lib ... why?

But If I try to build the solution I get the above list of errors "error  LNK1181" ????

Why the project that biuild does not give us a .lib project ?

Why we get some 
LNK1181 errors ?

****** 
if I use compiler Command PROMPT 10.1 I get some errors (LNK2019 and LNK1120):
libifcoremt.lib(for_main.obj) : error LNK2019: unresolved external symbol _MAIN_
_ referenced in function _main
77curve_aux_adi.exe : fatal error LNK1120: 1 unresolved externals


Someone very nice give us a tip please !!

Many thanks !!
0 Kudos
50 Replies
Highlighted
Beginner
49 Views

*release

0 Kudos
Highlighted
49 Views

Would you please attach a zip of the whole project so I can look at it?

0 Kudos
Highlighted
Beginner
49 Views

Here the whole project.

Thx so much

0 Kudos
Highlighted
49 Views

You didn't select "All configurations" before changing the properties. Select the Debug configuration and make the same changes I suggested above.

0 Kudos
Highlighted
Beginner
49 Views

ooooooooooookkkkkkkkkkkkk! finally

========== Build: 0 succeeded, 0 failed, 37 up-to-date, 0 skipped ==========

 

thx a lot!!!!!!!!!!

0 Kudos
Highlighted
Beginner
49 Views

''Visual studio cannot debug because a debug target has not been specified''

what means?

0 Kudos
Highlighted
49 Views

It means the executable project has no EXE specified in the Debugging > Command property. This is usually $(TargetPath) which combines the Output Directory, Target Name and Target Extension properties from the General page. It could also be that you don't have the executable project selected as the "Startup Project" - this is indicated by the project name being shown in bold font in the Solution Explorer pane. If that's the case, right click on the executable project and select "Set as startup project".

0 Kudos
Highlighted
Beginner
49 Views

The program '[4208] main_accoppiamento.exe' has exited with code 1 (0x1) -main accoppiamento

dll_analisi_statistica.dll doesn't exist on your computer- main analisi statistica


The program '[6568] main_curve_unita.exe' has exited with code -1073741510 (0xc000013a)..main_curve_unità

The program '[432] dinamica.exe' has exited with code -1 (0xffffffff).main_dinamica

The program '[8800] main_regressione.exe' has exited with code 1 (0x1).main_regressione

 

The program '[8288] simcent.exe' has exited with code -1 (0xffffffff).main_simcent

The program '[6220] stazionario.exe' has exited with code -1 (0xffffffff). main_stazionarioNW

regressione isn't an exe file-main_regressione

this happens when I select the "Startup Project". The other ones It says aren't .exe.

If I set $(TargetPath) project to project ....nothing!

 

0 Kudos
Highlighted
49 Views

So now you have a different problem in that a DLL that your executable needs isn't where Windows is looking for it. Copy that DLL into the folder with the EXE.

0 Kudos
Highlighted
Beginner
49 Views

in the folder with the exe dll_accoppiamento exist yet :-(

0 Kudos
Highlighted
Beginner
49 Views

This comment has been moved to its own thread
0 Kudos