Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SL00
Beginner
505 Views

Undefined symbols for architecture x86_64: "_ompi_buffer_detach_f08", referenced from

Dear all,

I built Openmpi with ifort successfully.

I am trying to use Openmpi with ifort but got the following error,

Undefined symbols for architecture x86_64:

  "_ompi_buffer_detach_f08", referenced from:

System: macOS Catalina

openmpi-4.0.5.tar.gz

$ ./configure --prefix=/usr/local/share/

$ make all install

 

Intel fortran

m_fcompxe_2020.2.899.dmg

 

Any idea about how to fix this?

 

Best regards,

 

Sean

 

0 Kudos
4 Replies
Ron_Green
Moderator
502 Views

you might need to read the OpenMPI configure options.  I believe you need to set the Fortran compiler to Intel.  Default is normally gfortran  FC=ifort for example. 

Or search for how to build OpenMPI for Intel Fortran.

SL00
Beginner
478 Views

Thanks.

It was configured with ifort because GCC was not installed in the macOS,

that is why I didn't specify the FC in the configuration file.

This was identified to be an issue of Intel Fortran as can be seen from the following discussion.

I don't know if this issue has been reported to Intel Fortran development team.

https://github.com/open-mpi/ompi/issues/7615

https://ntq1982.github.io/files/20200621.html

 

Kerry_K_
Novice
395 Views

I had the same problem and here's how I made openmpi work for macOS 10.15.7, Xcode 11.7,  intel parallel studio xe 19.1.3.301 and openMPI 4.0.5.  Configure openmpi 4.0.5:

./configure --prefix=/opt/openmpi CC=icc CXX=icc F77=ifort FC=ifort  lt_prog_compiler_wl_FC=-Wl,
Then when that finishes, open up the libtool generated by configure in your text editor and change lines 11837 to 11841 to 
# Additional compiler flags for building library objects.
pic_flag=" -fno-common -fPIC"

# How to pass a linker flag through the compiler.
wl="-Wl,"

Then make and install openmpi:

sudo make all install 

 

And then another tedious compiler and system upgrade day comes to a close...

 

Kerry_K_
Novice
394 Views

Also, I after upgrading the PSXE today, I had the zsh bug with 

source /opt/intel/bin/compilervars.sh intel64

 where it complained

remove_duplicate_paths:4: bad substitution
remove_duplicate_paths:4: bad substitution
...

 and this fix worked for that.

Reply