Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
154 Views

VS 2015/Intel 2015 Composer - Fortran

I have completed the installation of VS 2015 and Intel Composer XE 2015 (15.0.1394.14.XE) porting from VS2010 and Intel Fortran 2011 and I have encountered several issues.

My first install of Intel Composer resulted in the inability to build any of my existing fortran projects, so I uninstalled and reinstalled it. They are now able to "build" in that all of the object files and executables get built in the output directory but VS reports that the projects have failed for no apparent reason. The logs are also missing any failure message The resulting executables run successfully, much as they did under the previous VS/Intel compiler integration. I haven't been able to find any mention of this issue elsewhere.

There is also no syntax coloring present for any of my .f90 files. I have tried everything present in this thread: https://software.intel.com/en-us/forums/intel-visual-fortran-compiler-for-windows/topic/598035, but to no avail. I am left to either uninstall and reinstall (again).

Any ideas?

 

0 Kudos
14 Replies
Highlighted
Employee
154 Views

Sorry to hear about the issues. Some issues with the VS source editor and keyword coloring surfaced recently for others using VS2015 after installing our PSXE 2017 Update 2. You might be experiencing the same given you using VS 2015.

You might try clearing the cache files as discussed in the post here.  If that does not work, then unfortunately try another uninstall/reinstall of at least the Intel Composer.

0 Kudos
Highlighted
Black Belt Retired Employee
154 Views

I suspect that the two problems are related. See https://software.intel.com/en-us/articles/problem-fortran-source-files-not-compiled-when-building-in-visual-studio

0 Kudos
Highlighted
Beginner
154 Views

Clearing the cache resolved the syntax highlighting issue--thanks!

I am still, however, encountering the build issues where no build is "successful," but the executables and object files are created.

0 Kudos
Highlighted
Beginner
154 Views

I am also unable to create a new project. When I attempt to do so I receive the error message "Object reference not set to an instance of an object". I have checked the length of my path variable and it does not exceed the 2048 character limit, which was the suggested fix i have found several places. 

 

0 Kudos
Highlighted
Employee
154 Views

It sounds similar to the situation discussed in this thread where not everything was getting cleared from a previous release leading to the error you cited.

Are you using the Visual Studio Shell included with the Intel Visual Fortran package or standalone Visual Studio version?

Was it your plan/interest to remove the older combination of VS2010+IVF 2011 and just have have/use VS2015+PSXE 2015 or having both combinations available?

0 Kudos
Highlighted
Beginner
154 Views

We are using the Visual Studio Shell included with Intel Visual Fortran.

We removed IVF 2011, but I still have VS 2010 on my machine. Our plan is to use VS 2015 + IVF 2015. Could the presence of VS 2010 be causing the issue? Are you only able to have one version of VS on the machine? We are, however, experiencing this issue on a machine that didn't have a previous version of VS or IVF. 

0 Kudos
Highlighted
Employee
154 Views

I do not recognize the version string you provided earlier of: 15.0.1394.14.XE.  It seems like our VS integration component version id but I have not been able to match it up.

A few clarifications, our PSXE 2015 release supports VS 2015 starting with our PSXE 2015 Update 5 release. I don’t know which specific update version you have installed but if its earlier than update 5 then that could be the issue with the VS 2015 integration on both of your systems.

VS2010 Shell is shipped with the PSXE 2015 release.

You should be able to have both VS2010 Shell and VS2015 installed simultaneously and the PSXE 2015 integrated with both (assuming you have PSXE 2015 Update 5 or newer).

0 Kudos
Highlighted
Beginner
154 Views

It appears to be update 7. Here is the entire version string:

Intel® Parallel Studio XE 2015 Update 7 Composer Edition for C++ Windows* Integration for Microsoft* Visual Studio* 2015, Version 15.0.1394.14.XE, Copyright © 2002-2015 Intel Corporation. All rights reserved.
* Other names and brands may be claimed as the property of others.

0 Kudos
Highlighted
Beginner
154 Views

Here is the Fortran version string:

Intel® Parallel Studio XE 2015 Update 7 Composer Edition for Fortran Windows* Integration for Microsoft Visual Studio* 2015, Version 15.0.0127.14, Copyright © 2002-2015 Intel Corporation. All rights reserved.
* Other names and brands may be claimed as the property of others.

0 Kudos
Highlighted
Beginner
154 Views

Here is the error log in the cache folder ComponentModelCache. It becomes present after I attempt to create a new project.

0 Kudos
Highlighted
Employee
154 Views

Ok, good to see it is PSXE 2015 update 7. That eliminates one possible cause. The log you tried to share did not upload correctly. It is zero-length.

From either system, would it be possible to obtain installation logs?

Those are typically available under the %TEMP% setting. If you drop that string into the address bar in File Explorer you might see folders with the name containing: pset_tmp_PSXE2015  (The folder where these are is like: C:\Users\<userid>\AppData\Local\Temp)

0 Kudos
Highlighted
Beginner
154 Views

They should work now. The logs are attached.

0 Kudos
Highlighted
Employee
154 Views

Thank you for the logs and error file. After studying those I did not find anything obvious in the installation logs so I forwarded them to our integration Developers along with the VS cache error log to request their help and analyzing them all. I’m sorry I don’t have other suggestions for things to try at the moment.

0 Kudos
Highlighted
Employee
154 Views

Our Integration Developers asked if you can provide the Visual Studio activity log from the system where you experience the issue creating new projects.

To generate this you need to run Visual Studio from command line with /log switch ( i.e.   devenv /log ). To do this, open an Intel Fortran command-prompt window and issue the devenv command in.

By default logs are stored in:
%APPDATA%\Roaming\Microsoft\VisualStudio\<version>\ActivityLog.xml

After you launch Visual Studio, please try to create a new project to trigger the error "Object reference not set to an instance of an object".

They also requested information about that what version of MiscUtilities is installed in GAC (Global Assembly Cache)?

This can be found in file system path: C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Intel.Misc.Utilities

What they are looking for is the name of newest folder named like: v4.0_17.0.14.0__5caa3becd8c4c9ee

Thank you

0 Kudos