Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646

VS10 / Composer XE 2013 errors

davidspurr
Beginner
118 Views

If I try to double click a file in the IDE solution explorer I get a "library not registered" error.  This error occurs whether the file is already open or not.

Means I cannot view files that are not already open.

This only occurred in the last few weeks, not long after I installed the lasted update but not immeidately after.  Initially worked fine (if I recall correctly.

I closed & re-opened VS, but still the same occurred.

==
Also when I try to view 'Project Properties' the left hand panel is fully populated as normal, but there is no info in the right hand panel (ie. it is blank / white space).  Applies for both Win32 and x64, and both Debug and Release.

==
Intall details are:

    Microsoft Visual Studio 2010
    Version 10.0.30319.1 RTMRel
    Microsoft .NET Framework
    Version 4.0.30319 RTMRel
    Intel(R) Visual Fortran Composer XE 2013

    Security Update for Visual Studio 2010 Shell (Integrated) - ENU (KB2251489)   KB2251489
    Security Update for Visual Studio 2010 Shell (Integrated) - ENU (KB2644980)   KB2644980

0 Kudos
2 Replies
davidspurr
Beginner
118 Views

Further issue (presumably related).  If I attempt to Build the exe, I get the following message:

  "Error    1    The Fortran compiler (ifort.exe) cannot be found."       

Anonymous66
Valued Contributor I
118 Views

Are you able to run the compiler from the command line? This sounds like an issue with your  integration getting corrupted. I would suggest reinstalling the IDE integration part of the compiler.

Reply